收藏
回答

关于小程序image组件的src问题。

我从服务器获取到图片的http地址,然后赋予到Image组件内。Image组件还是空的。

但是从console内点击图片路径,是能看到图片的。

不太明白问题出在哪里。





官方能回答一下这个问题么



有没有大佬回答一下......急求。




如果我把这个路径直接写在组件里面,图片是能加载出来的,但是通过变量赋值,就不行。

最后一次编辑于  2018-08-03
回答关注问题邀请回答
收藏

5 个回答

  • PiyRiK🤡
    PiyRiK🤡
    星期六 09:29

    楼主 解决了吗 我也遇到了 怎么解决的 很是扯淡 图片打印出来了 浏览器能访问 然后直接copy到image里也好使 就是赋值不好使 不知道怎么回事

    星期六 09:29
    有用
    回复
  • 加清
    加清
    2019-12-28

    我也遇到同样的问题,最后通过设置图片的样式,width和height,不知怎么得,图片就出来了

    2019-12-28
    有用
    回复 1
    • PiyRiK🤡
      PiyRiK🤡
      星期六 09:29
      楼主 解决了吗 我也遇到了 怎么解决的 很是扯淡 图片打印出来了 浏览器能访问 然后直接copy到image里也好使 就是赋值不好使 不知道怎么回事
      星期六 09:29
      回复
  • ice
    ice
    2018-07-31

    设置下图片的高宽

    2018-07-31
    有用
    回复 5
    • Pickle
      Pickle
      2018-08-03

      图片样式没问题,就是路径加载的问题

      2018-08-03
      回复
    • ice
      ice
      2018-08-03回复Pickle

      如果你怀疑是路径加载问题,你可以单独搞一个测试页,先排除这个疑虑

      2018-08-03
      回复
    • Pickle
      Pickle
      2018-08-03回复ice

      如果我直接写一个url是可以的,但是通过变量赋值就不行,

      setData也不行

      2018-08-03
      回复
    • ice
      ice
      2018-08-03回复Pickle

      能贴代码不能,光看你说其实难解决问题

      2018-08-03
      回复
    • ice
      ice
      2018-08-09回复Pickle

      贴代码

      2018-08-09
      回复
  • WeiLoong·M
    WeiLoong·M
    2018-07-28

    检查一下你的canvas 覆盖在图片上了

    2018-07-28
    有用
    回复 1
    • Pickle
      Pickle
      2018-08-03

      并不是,我故意在最后面写了一个image。

      2018-08-03
      回复
  • 南风
    南风
    2018-07-28

    猜测是样式的问题,只是你没看到吧

    2018-07-28
    有用
    回复 1
    • Pickle
      Pickle
      2018-08-03

      图片的样式是没有问题的

      2018-08-03
      回复
登录 后发表内容