收藏
回答

构建npm之后,node_modules中的依赖没有构建出来miniprogram_npm,导致报错

框架类型 问题类型 操作系统 工具版本
小程序 Bug macOS 1.03.2011120

https://developers.weixin.qq.com/miniprogram/dev/devtools/npm.html

构建npm之后,node_modules中的依赖没有构建出来miniprogram_npm,导致报错找不到依赖

使用的是微信小程序官方demo:minicode-10

回答关注问题邀请回答
收藏

4 个回答

  • brave
    brave
    2020-12-17

    删除 node_modules 和 miniprogram_npm 这两个文件夹,按照:

    npm i 安装模块 → 使用npm模块→ 构建NPM

    2020-12-17
    有用 2
    回复 4
    • 料事如
      料事如
      2020-12-17
      不生效
      2020-12-17
      回复
    • ꧁꫞唐少꫞꧂
      ꧁꫞唐少꫞꧂
      2020-12-18
      在这个文件的同级目录下执行npm install
      2020-12-18
      回复
    • 41676f6e694e656d6f
      41676f6e694e656d6f
      2020-12-26回复料事如
      请问你解决了吗?
      2020-12-26
      回复
    • 希望的田野
      希望的田野
      05-10
      这个怎么解决?
      05-10
      回复
  • 大猫
    大猫
    01-05

    packNpmManually 改成false

    01-05
    有用 1
    回复 1
    • 希望的田野
      希望的田野
      05-10
      修改之后,可以构建了,但是miniprogram_npm文件 没有生成
      05-10
      回复
  • 嘚瑟妞🍎
    嘚瑟妞🍎
    星期二 11:15

    解决了吗?最后是怎么搞的?求回复

    星期二 11:15
    有用
    回复
  • 翁小豪
    翁小豪
    09-03

    删除 node_modules 和 miniprogram_npm (其他文档推荐的miniprogram) 这两个文件夹,

    设置

    "packNpmManually": true,

    "packNpmRelationList": [

    {

    "packageJsonPath": "package.json",

    "miniprogramNpmDistDir": "./"

    }

    ],


    按照:

    npm i 安装模块 → 使用npm模块→ 构建NPM


    09-03
    有用
    回复
登录 后发表内容
问题标签