收藏
回答

引用发布版插件报错

问题类型 插件 AppID 插件版本号 AppID 操作系统 微信版本 基础库版本
Bug wx70358fb44d63c53c 1.0.0 wx8d8b96b7875e16f6 Android 7.0 2.6.2

插件发布后,将版本号改为正式版本号后就报下面的错误(插件的申请及授权在后台已经做完)



如果将版本号改为开发过程中使用的dev,则一切正常:



报错信息提示是引用了空对象的match属性,全局搜索了我整个工程的"match“字符串,未找到引用的语句。

在另外新的小程序中引用新发布的插件也报同样的错误。

好不容易插件开发完成,发布后,却不能使用,卡在这儿了。


最后一次编辑于  2019-03-09
回答关注问题邀请回答
收藏

2 个回答

  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2019-03-11

    请问是在开发插件呢还是在小程序项目中使用插件?

    2019-03-11
    赞同
    回复 10
    • gzlj
      gzlj
      2019-03-11

      在开发插件的工程中以及在新的小程序项目中,使用插件的发布版本1.0.0,都会报如上错误。

      2019-03-11
      回复
    • 小程序技术专员-LastLeaf
      小程序技术专员-LastLeaf
      2019-03-11回复gzlj

      插件项目中应当只能使用 dev 。小程序项目中如有问题,麻烦提供一下开发者工具版本号以及在项目设置中选择的基础库版本号。

      2019-03-11
      回复
    • gzlj
      gzlj
      2019-03-11回复小程序技术专员-LastLeaf

      在新的小程序项目中引用也有报错,开发者工具版本号:1.02.1902010,检查更新提示已经是最新版。

      基础库版本号:


      这些我都试过了,都报错。


      2019-03-11
      回复
    • 小程序技术专员-LastLeaf
      小程序技术专员-LastLeaf
      2019-03-11回复gzlj

      感觉是基础库的一个报错提示有问题。


      请问插件的页面是不是都正常声明在了 plugin.json 的 pages 下了呢?

      2019-03-11
      回复
    • gzlj
      gzlj
      2019-03-11回复小程序技术专员-LastLeaf

      plugin.json文件内容:


      但plugin目录下有一个页面,由于暂未使用,未在plugin.json文件中声明,是需要声明下这个页面吗?

      2019-03-11
      回复
    查看更多(5)
  • 铭锋科技
    铭锋科技
    2019-03-09

    插件名称发来试下

    2019-03-09
    赞同
    回复 1
    • gzlj
      gzlj
      2019-03-10

      插件名称:星希智能组件

      2019-03-10
      回复
登录 后发表内容