收藏
回答

怎么兼容observers

框架类型 问题类型 终端类型 微信版本 基础库版本
小程序 需求 客户端 7.0.0 2.5.2

想询问一下要怎么兼容新基础库的一些好用的功能。 如果是新的api或者组件,通过查询版本号看能不能使用,可是像这种observers, optionalTypes配置类型的,要怎么让低版本的也有相同的效果,难道要写两套代码吗?
还有就是比如图里的optionalTypes属性是2.6.5才能使用,这种配置类型的要怎么兼容


回答关注问题邀请回答
收藏

1 个回答

  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    2019-05-23

    看下这里的文档介绍https://developers.weixin.qq.com/miniprogram/dev/framework/compatibility.html

    2019-05-23
    有用
    回复 4
    • + +
      + +
      2019-05-23

      我知道这个呀,如果是api之类的,这个判断完 if else 兼容就好了。可是这种监听器,有点像组件的配置项,具体要怎么兼容呢

      2019-05-23
      2
      回复
    • 子咻
      子咻
      2019-06-20回复+ +

      楼主有找到方法吗?遇到同样的问题,网上居然搜不到半点有用的资料

      2019-06-20
      回复
    • + +
      + +
      2019-06-21回复子咻

      没有找到方法,就退一步用旧的属性吧,不用这个监听器了,网上确实找不到相关的帖子

      2019-06-21
      回复
    • 袁
      07-09回复+ +
      旧版的属性是哪个。。。。
      07-09
      回复
登录 后发表内容