收藏
回答

安卓小程序蓝牙不能正常连接ble设备,报10006

问题模块 框架类型 问题类型 API/组件名称 终端类型 操作系统 微信版本 基础库版本
API和组件 小程序 Bug 蓝牙 客户端 Android 6.6.7 2.2.2

在部分机型下小程序不能正常连接BLE蓝牙,报错代码:10006(文档中描述的是“no connection  当前连接已断开”),但是在同样的机型上,使用安卓原生app去连接就没有问题。

需要说明的是,安卓app之前也出现过类似不能连接的问题,后来参考这篇博客解决了:(https://blog.csdn.net/landon_xu/article/details/53064517),解决办法:把 transport 设置为TRANSPORT_LE就行了。


期待官方技术人员或者其他开发者提供解答。


目前测到不能正常连接的机型:

一加3T     7.1.1

奇酷N4S   6.0

小米5x


能够正常连接的机型:

iPhone 6

荣耀7     5.0

三星Note8   8.0



小程序报错截图如下


最后一次编辑于  2018-08-14
回答关注问题邀请回答
收藏

3 个回答

  • Tiger Nong
    Tiger Nong
    2018-09-06

    我也是有遇到这样的情况,安卓手机频繁的出现连接已断开的错误码10006

    2018-09-06
    赞同
    回复
  • 马鹏云
    马鹏云
    2018-09-04

    顶一下

    2018-09-04
    赞同
    回复
  • Lee
    Lee
    2018-08-13

    官方能帮忙回答一下这个问题吗?

    2018-08-13
    赞同
    回复
登录 后发表内容