收藏
回答

小程序map组件polyline内只有一个点的时候,工具渲染的时候会提示渲染层问题。

框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
小程序 Bug map 工具 7.0.15 2.13.0

小程序map组件polyline内只有一个点的时候,工具渲染的时候会提示渲染层问题无法识别length,length值是undefine

polyline: [{points: [{latitude: "30.274670135524293", longitude: "120.15311927951234"}], width:10, borderWidth:2, colorList: ['#00FF00']}]

如果polyline数组是个空数组或者数组元素大于2的时候不会有渲染层问题,但是对于业务来说如果第一个点是由用户提供或者由定位提供,则肯定有一个时间点这个数组内只有一个点。

(然后顺便说一下这个提交bug的毛病,我提交的是一个开发者工具的问题,为毛要我提交微信的版本号还是必填字段)

回答关注问题邀请回答
收藏

1 个回答

登录 后发表内容
问题标签