收藏
回答

input层级高

框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
小程序 Bug input 工具 7.0.5 2.7.7


这input层级过高怎末搞?网上说判断但是我这里是显示在悬浮view上 判断不能用  说是用

cover-view

也不管用啊!!! 咋办???

回答关注问题邀请回答
收藏

3 个回答

  • 小程序商城定制开发2600元全包
    小程序商城定制开发2600元全包
    06-07

    因为微信小程序默认就是原生组件camera、canvas、input(仅在focus时表现为原生组件)、live-player、live、pusher、map、textarea、video的层级是最高的,官方的解决方案也不行,最后通过几行代码解决。


    把下面那个层级较低的盒子,给他固定定位,定位到屏幕下方,层级设高一点就行了

     position: fixed;

     left: 0;

     bottom: 0;

     z-index: 9999;


    06-07
    有用 1
    回复
  • 吴迪
    吴迪
    2019-07-25

    https://developers.weixin.qq.com/miniprogram/dev/component/native-component.html

    看下这个

    2019-07-25
    有用
    回复 1
    • 成阳
      成阳
      2019-07-25
      还是不行
      2019-07-25
      回复
  • 成阳
    成阳
    2019-07-25



    2019-07-25
    有用
    回复 2
    • 成阳
      成阳
      2019-07-25
      这个样子
      2019-07-25
      回复
    • 卢霄霄
      卢霄霄
      2019-07-25回复成阳

      1、同层渲染马上来了

      2、没事的时候用个view代替input,需要输入的时候再显示 input

      2019-07-25
      回复
登录 后发表内容