收藏
回答

微信开发者工具导致了我使用wepy一直报错

框架类型 问题类型 操作系统 工具版本
小程序 Bug Windows v.1.02.1910282

事情是这样的,每次官方迭代新版本的微信开发者工具我都会主动去更新,但是这次,把我害惨了,我的微信开发者工具从版本  v.1.02.1907300 更新到 v.1.02.1910282  后,导致了我基于wepy使用的this.$apply()抛出异常,这个是我问题还是官方的微信开发者版本的问题导致的。

一直抛出 WEPY  Can not call $apply in $apply process  但是我微信开发者工具版本还原到 v.1.02.1907300 后又没事了。


回答关注问题邀请回答
收藏

6 个回答

  • Clarence
    Clarence
    2020-01-02

    我也遇到了该问题,Can not call $apply in $apply process。

    这种问题我发现全部都是出现在repeat组件的情况下,我的wepy版本是1.7.2,发现若是新版本微信开发工具只要去掉该组件就可以避免该错误,但Wepy1.X版本规定“当需要循环渲染WePY组件时(类似于通过wx:for循环渲染原生的wxml标签),必须使用WePY定义的辅助标签<repeat>”,没办法只能回退开发工具版本了。升级需谨慎!!!

    2020-01-02
    有用 1
    回复
  • Geefib
    Geefib
    2019-11-06

    +1 有什么方案吗?

    真机调试一直报这个错

    Unhandled promise rejection Error: Can not call $apply in $apply process

    2019-11-06
    有用 1
    回复 4
    • huajun
      huajun
      2019-11-15
      将版本回退至v.1.02.1907300,在进行真机测试
      2019-11-15
      回复
    • 困困的囡囡
      困困的囡囡
      2020-02-28回复huajun
      回退版本后真机测试是没有问题,但是上传体验版小程序还是不能正常运行,请问这个怎么解决呢
      2020-02-28
      回复
    • KAM
      KAM
      2020-03-30
      如果是小程序开发者工具导致的问题建议将小程序开发者工具版本回退下
      2020-03-30
      回复
    • Geefib
      Geefib
      2020-03-30回复KAM
      目前用最新版是ok的。不过wepy1.7.2的组件是假组件,目前导致了开发中遇到很多问题
      2020-03-30
      回复
  • Admin²⁰²²
    Admin²⁰²²
    2020-03-27

    wepy都N久不更新了。

    楼主还在坚持用吗?

    以后估计兼容性会越来越不好。头大了吧

    2020-03-27
    有用
    回复 8
    • Geefib
      Geefib
      2020-03-30
      用了1年多了,现在不维护了,想迁移框架,调研了一下发现哪个框架迁移成本都很高
      2020-03-30
      回复
    • Admin²⁰²²
      Admin²⁰²²
      2020-03-30回复Geefib
      wepy貌似是官方的吧?不维护真的头大。
      2020-03-30
      回复
    • Geefib
      Geefib
      2020-03-30回复Admin²⁰²²
      是的只有1个人,而且1.xx作者已经放弃,全部投入2.xx。然后1.xx到2.xx也是只有重构......
      2020-03-30
      回复
    • Admin²⁰²²
      Admin²⁰²²
      2020-03-30回复Geefib
      感觉wepy的官方人员已经跳槽走了。
      然后官方现在又在推新的叫啥kbone的框架?估计这个也会同样结局?
      2020-03-30
      回复
    • Geefib
      Geefib
      2020-03-30回复Admin²⁰²²
      很慌呀,目前看来迁移成本较小的就是uni-app
      2020-03-30
      回复
    查看更多(3)
  • 困困的囡囡
    困困的囡囡
    2020-02-28

    回退版本后真机测试是没有问题,但是上传体验版小程序还是不能正常运行,请问这个怎么解决呢

    2020-02-28
    有用
    回复 4
    • KAM
      KAM
      2020-02-28
      这个我建议你写日志debug
      2020-02-28
      回复
    • 困困的囡囡
      困困的囡囡
      2020-02-28回复KAM
      具体怎么做
      2020-02-28
      回复
    • KAM
      KAM
      2020-02-28
      首先你得知道是什么导致报错的。关于日志,可以使用微信官场提供的日志功能,也可以使用云开发的方式主动上传日志。还可以通过打开小程序的界面,关闭小程序左边有三个点(更多)的,里面有个反馈的功能,你反馈一下,能在小程序的公众号后台看到小程序运行的调用小程序API的日志,很详细的
      2020-02-28
      回复
    • 困困的囡囡
      困困的囡囡
      2020-02-28回复KAM
      我debugger之后知道代码报错所在,可是这句代码删掉之后没有报错小程序也不正常执行
      2020-02-28
      回复
  • Rohlin🙉🙈🙊
    Rohlin🙉🙈🙊
    2020-02-11

    话不多说 已经好几个月过去了 还是不修复 坑的一批

    2020-02-11
    有用
    回复 1
    • 困困的囡囡
      困困的囡囡
      2020-02-28
      您好这个问题解决了吗
      2020-02-28
      回复
  • 陈Ys
    陈Ys
    2019-10-29

    关掉es6转es5

    2019-10-29
    有用
    回复 5
    • KAM
      KAM
      2019-10-29
      尝试过了,还是报错,开发者工具版本回退后就可以了
      2019-10-29
      回复
    • 豆浆不加糖
      豆浆不加糖
      2019-11-01回复KAM
      微信开发者工具无法打开.wpy文件怎么办
      2019-11-01
      回复
    • d x
      d x
      2019-12-27回复KAM
      所以你最后怎么处理的呢?就改回用旧版本了么?
      2019-12-27
      回复
    • KAM
      KAM
      2020-02-28回复d x
      我还是改回旧版本
      2020-02-28
      回复
    • KAM
      KAM
      2020-02-28回复豆浆不加糖
      用其他IDE开发吧
      2020-02-28
      回复
登录 后发表内容
问题标签