收藏
回答

新版本开发工具生成模板代码里wafer-node-sdk依赖库版本号的问题

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug macOS 1.02.1806080

使用v1.02.1806080版本开发者工具生成项目的package.json 中 "wafer-node-sdk"版本为 "^1.3.4",此时上传测试代码(Node.js环境)在安装依赖库环节会报错:

{"code":-1,"reason":"npm ERR! Unexpected end of input at 1:40721 npm ERR! -karma\":\"latest\",\"grunt-nuget\":\"latest\",\"grunt-benchmark\":\"latest\",\"g npm ERR! ^ npm ERR! A complete log of this run can be found in: npm ERR! /hom"}


朋友使用的是v1.02.1803210版本的开发工具生成的模板代码中"wafer-node-sdk"版本为 "^1.0.7",所以尝试将其"wafer-node-sdk"版本号改为"^1.0.7",结果就能够正常上传部署了。


但是npm^符号不是会匹配最新的大版本依赖包嘛?比如^1.0.7会匹配所有1.x.x的包,包括1.3.4,但是不包括2.0.0。


表示一脸懵逼,求解答。。。。



最后一次编辑于  2018-06-09  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

1 个回答

  • vaan
    vaan
    2018-06-10

    特地录制了一段操作视频https://market-1256 882560.cos.ap-shanghai.myqcloud.com/failed/failed.mov

    希望论坛里有大神能够解答


    2018-06-10
    赞同
    回复