收藏
回答

app.js错误:TypeError :function.prototype.apply...?

app.js错误:TypeError: Function.prototype.apply was called on WeakMap.prototype.get, which is a string and not a function。

回答关注问题邀请回答
收藏

13 个回答

  • 喷火娃🐰
    喷火娃🐰
    09-23
    我是用hbuilder开发,在微信开发者工具里运行,引用地图插件的时候在app.json里引入插件包 "plugins": {
            "chooseLocation": {
            "version": "1.0.6",
            "provider": "wx76a9a06e5b4e693e"
            }
        }就会报这个错,已经重新拉代码下依赖了,还是不行。有大佬知道怎么解决吗?
    
    09-23
    有用 2
    回复 1
    • 段晨龙
      段晨龙
      10-28
      兄弟解决了嘛,我是引的直播组件,也是报错
      10-28
      回复
  • ......
    ......
    08-18

    我也出现这个问题了 自己排查了一下安装包 是因为用了QS的6.10.1版本 回退到6.9.6版本就好了

    08-18
    有用 3
    回复 2
    • 啊哈
      啊哈
      09-18
      虽然项目中没有直接依赖QS,查了一下内部其他包依赖到了6.10.1。外部指定一下就可以了
      09-18
      1
      回复
    • spicycandy🍬
      spicycandy🍬
      11-11
      谢谢,解决了,跟你同样的原因
      11-11
      回复
  • Christine
    Christine
    09-08

    依赖问题,我重新克隆了一下代码,并重装了依赖,就解决了

    09-08
    有用 1
    回复
  • chh
    chh
    04-21

    是用vscode做小程序开发吗?

    04-21
    有用 1
    回复 6
    • 澜希
      澜希
      发表于移动端
      04-21
      是的
      04-21
      回复
    • chh
      chh
      04-21回复澜希
      那在vscode中就应该有app.js文件了呀,你是自己开发的,还是接手别人的代码
      04-21
      回复
    • 澜希
      澜希
      发表于移动端
      04-21回复chh
      接手别人的
      04-21
      回复
    • chh
      chh
      04-21回复澜希
      ...里面有坑估计
      04-21
      回复
    • yflee
      yflee
      05-25
      解决了吗?我这边也是 用的vscode编译uniapp启动也没报错 在小程序开发者工具中就报这个错
      05-25
      回复
    查看更多(1)
  • Saber
    Saber
    08-21

    我是把代码复制到老项目有报这个错,但是新建项目却没有报这个错,不知道哪里有冲突,代码也是uniapp生成的,不好查询哪里报错

    08-21
    有用
    回复
  • 古笙
    古笙
    08-12

    请问楼主解决了吗,我也遇到相同的问题

    08-12
    有用
    回复 2
    • 澜希
      澜希
      10-11
      没有,今天这个错误重新出来了
      10-11
      回复
    • 澜希
      澜希
      10-11
      解决了,我的问题出在npm包的qs版本和package.json中的qs版本号不一致。所以最后把package.json中的版本号改成npm包中的qs版本一致保存,重新npm install就可以了
      10-11
      回复
  • 刺勋
    刺勋
    06-22

    你好解决了吗

    06-22
    有用
    回复
  • Kop
    Kop
    05-26

    你好 我也遇到这个错误,请问解决了吗


    05-26
    有用
    回复
  • yflee
    yflee
    05-25

    解决了吗?我这边也是 用的vscode编译uniapp启动也没报错 在小程序开发者工具中就报这个错 头疼

    05-25
    有用
    回复 3
    • Kop
      Kop
      05-26
      你好 请问你解决了吗
      05-26
      回复
    • yflee
      yflee
      05-26回复Kop
      在原分支搞了好久都没解决,什么方法都试了,  最后我把分支删了重新建了一个 然后重新yarn就好了
      05-26
      回复
    • Kop
      Kop
      05-26回复yflee
      我把项目删了重新git clone 再npm install都不行。。
      05-26
      回复
  • 哈哈哈・ω・
    哈哈哈・ω・
    05-08

    你好 解决了嘛

    05-08
    有用
    回复

正在加载...

登录 后发表内容