收藏
回答

EventEmitter memory leak detected.

框架类型 问题类型 终端类型 微信版本 基础库版本
小程序 Bug 工具 6.6.7 2.1.3

(node) warning: possible EventEmitter memory leak detected. 16 listeners added. Use emitter.setMaxListeners() to increase limit.

这个提示怎么解决

回答关注问题邀请回答
收藏

5 个回答

  • David
    David
    2018-07-14

    我也遇到这个问题,2.1.3会出现,2.1.2都不会出现。。。

    2018-07-14
    有用 2
    回复 1
    • 肖杨
      肖杨
      2018-07-16

      2.2.0也会出现   估计是官方基础库的问题

      2018-07-16
      1
      回复
  • 咪儿
    咪儿
    2018-07-17

    我也出这个问题了,调到1.9.6调试版本就没有报这个错了

    2018-07-17
    有用 1
    回复
  • ・ω・ €  j.h
    ・ω・ € j.h
    2018-07-16

    我一直把基础版本调到1.7.0测试,今天突然转到2.1.3也出现这样的问题,为什么官方没人出来解答的呢?

    2018-07-16
    有用 1
    回复
  • 肖杨
    肖杨
    2018-07-13

    开发工具版本2.1.1 不会出现  2.1.3才会出现

    2018-07-13
    有用 1
    回复
  • 卢霄霄
    卢霄霄
    2018-07-13

    你可以在社区里搜索一下 “EventEmitter memory leak detected

    2018-07-13
    有用
    回复 12
    • 肖杨
      肖杨
      2018-07-13

      没有解决方案啊

      2018-07-13
      回复
    • 卢霄霄
      卢霄霄
      2018-07-13回复肖杨

      你有用到   createVideoContext  吗

      2018-07-13
      回复
    • 肖杨
      肖杨
      2018-07-13回复卢霄霄

      没有

      2018-07-13
      回复
    • 卢霄霄
      卢霄霄
      2018-07-13回复肖杨

      能看看你的页面吗,最好做个代码片段

      2018-07-13
      回复
    • 肖杨
      肖杨
      2018-07-13回复卢霄霄

      不知道是哪出的问题    就是一个简单的列表

      2018-07-13
      回复
    查看更多(7)
登录 后发表内容