收藏
回答

iOS开发工具包(1.8.7版本,包含支付功能)编译报错

https://developers.weixin.qq.com/doc/oplatform/Downloads/iOS_Resource.html

报错信息:

Undefined symbols for architecture arm64:

  "_OBJC_CLASS_$_WKWebpagePreferences", referenced from:

      objc-class-ref in libWeChatSDK.a(WapAuthHandler.o)

  "___isPlatformVersionAtLeast", referenced from:

      -[WXWebViewController viewDidLoad] in libWeChatSDK.a(WapAuthHandler.o)

ld: symbol(s) not found for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)
回答关注问题邀请回答
收藏

3 个回答

  • 微信技术专员-Abe
    微信技术专员-Abe
    2020-04-14
    1. 这两天会发布1.8.7.1版本,修复Xcode10编译不过问题
    2. 如果比较急的话可以使用1.8.6.2版本或者升级Xcode11
    2020-04-14
    有用
    回复 5
  • 勇气猪
    勇气猪
    2020-05-27

    我的用最新的xcode11.3和1.8.7.1版还是出现这个问题。急

    2020-05-27
    有用 2
    回复
  • 🍎猛🍎
    🍎猛🍎
    2020-04-14

    Xcode 版本 10.3 iOS版本: 9.0以上

    2020-04-14
    有用
    回复
登录 后发表内容
问题标签