收藏
回答

request:fail 小程序要求的 TLS 版本必须大于等于 1.2

一直报TLS版本必须大于等于1.2,但是我的服务器是使用的TSL1.2版本;求大神们指导。


回答关注问题邀请回答
收藏

1 个回答

  • 俊秀谦诚
    俊秀谦诚
    2019-04-19

    找到原因了。是因为我的nginx查是采用静态openssl方式编译,编译时使用的是0.9.8m版本的openssl,重新编译就好了。


    ./nginx -V

    如果不存在–with-openssl这样的编译参数,就说明Nginx采用的是动态方式编译的SSL,这种情况直接重启Nginx就好了,否则就是静态方式的,需要重新对Nginx进行编译。

    2019-04-19
    有用
    回复
登录 后发表内容