收藏
回答

wx.chooseWXPay 提示 jsapi param invalid appId

    // JS支付方法
    function pay(data) {
        console.log(data)
        wx.chooseWXPay({
            timestamp: data.timeStamp,
            nonceStr: data.nonceStr,
            package: data.package,
            signType: data.signType,
            paySign: data.paySign,
            success(res) {
                console.log(res)
            },
            fail(res) {
                console.log(res)
            },
        })
    }

接口响应数据

appId"XXX"
nonceStr"yqv4i5wyplmi4zwmftqfe04x9l8o3xm8"
order_no"202003250910033DD7D9BE"
package"prepay_id=wx2509095231590734806b07f51946415100"
paySign"25EEBF67BB2F7DA8788A65BE533D8913"
signType"MD5"
timeStamp"1585098605"

最后一次编辑于  03-25
回答关注问题邀请回答
收藏

1 个回答

  • 支付技术助手8
    支付技术助手8
    03-25

    您好,报这个错误,可能是你调起支付请求的APPID与你统一下单的APPID不一致引起,你调起支付请求用了这个你要用你统一下单中的APPID才对,请注意。

    03-25
    赞同
    回复 1
    • 绿·静·風
      绿·静·風
      03-25
      只有一个appid, 怎么肯不一样!!!
      03-25
      回复
登录 后发表内容
问题标签