收藏
回答

程序跳转提示需要配置声明

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows 2.3.2

- 当前 Bug 的表现(可附上截图)

开发工具中跳转:

点击小程序图片提示:

“navigateToMinProgram接口需要配置声明,否则没有办法跳转”

在真机调试中点击则无反应。

- 预期表现

没有配置声明提示。

- 复现路径


- 提供一个最简复现 Demo


最后一次编辑于  2018-11-06  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

3 个回答

  • 太有才了丶
    太有才了丶
    2018-11-06

    2018-11-06
    赞同
    回复 1
    • 旧颜
      旧颜
      2018-11-06

      你这边解决了吗?

      2018-11-06
      回复
  • 旧颜
    旧颜
    2018-11-06

    昨天还是正常的,同样的代码今天测试就出现问题。

    2018-11-06
    赞同
    回复 6
    • Bobo
      Bobo
      2018-11-07

      配置了测试时还能跳转,线上版发布后却不能跳转了,请问有遇到这个情况吗 也没有报错 难道跟编辑器版本库有关系么

      2018-11-07
      回复
    • 旧颜
      旧颜
      2018-11-07回复Bobo

      艹,哥们我也碰到了。发现低版本微信可以跳转,高版本的不行。更新了一下开发工具,用2.4.0库再编译了一遍,使用高版本微信测试没有问题,不知道提交正式版本会怎么样。你那边有结果了通知一下。

      2018-11-07
      回复
    • Bobo
      Bobo
      2018-11-07回复旧颜

      刚刚我也发现是因为版本库的问题,晕了,得重新提

      2018-11-07
      回复
    • Bobo
      Bobo
      2018-11-07回复旧颜

      我这边使用2.4.0版本库提交发布后还是跳不了....  官方那边说建议后台关联一下..

      2018-11-07
      回复
    • 旧颜
      旧颜
      2018-11-07回复Bobo

      他妈的!后台关联, 是绑定到同一个公众号吗?

      2018-11-07
      回复
    查看更多(1)
  • 🐠糖醋鱼
    🐠糖醋鱼
    2018-11-06

    https://developers.weixin.qq.com/community/develop/doc/0000ac39168d50641477b725c51c01

    2018-11-06
    赞同
    回复 1
    • 旧颜
      旧颜
      2018-11-06

      和官方文档没有关系。跳转确认都正常,这个借口配置声明第一次遇到,官方也没有说明。

      2018-11-06
      回复