收藏
回答

上一个版本没有强制更新,新版本增加了强制更新的代码,旧版本的用户可以新更新么

问题模块 框架类型 问题类型 API/组件名称 终端类型 操作系统 微信版本 基础库版本
API和组件 小程序 Bug wx.getUpdateManager() 客户端 6.6.7 2.0.9

上一个版本没有强制更新,现在这个版本增加了强制更新的代码,旧版本的用户可以通过强制更新更新小程序版本么

最后一次编辑于  2018-06-20
回答关注问题邀请回答
收藏

2 个回答

  • 发芽的土豆
    发芽的土豆
    2018-06-20

    不可以,仅针对用户更新到了最新版本的小程序才有效。

    举个例子:

    A(没有强制更新代码)

    B(有强制更新代码,这个版本不会被强制更新)

    C(这个版本才会强制更新)

    2018-06-20
    赞同 1
    回复 2
    • Z的人生
      Z的人生
      2018-06-20

      那就版的用户就只能使用旧的版本么,这样子是不是很不合理,因为强制更新的这个功能也是才有,之前是没有的

      2018-06-20
      回复
    • 发芽的土豆
      发芽的土豆
      2018-06-20回复Z的人生

      旧版本用户还是会采用微信旧有的更新机制来更新。不会一直使用旧版本的。这点您可以放心。

      强制更新只是更新速度更快了而已。

      2018-06-20
      2
      回复
  • Z的人生
    Z的人生
    2018-06-20
    老哥,你的例子我没看明白!!-_-
    2018-06-20
    赞同
    回复