收藏
回答

ext.json不能替换掉app.json的plugins

框架类型 问题类型 终端类型 微信版本 基础库版本
小程序 Bug 客户端 6.7 2.3

在app.json和ext.json里引用插件,开发工具都没有问题,可正常使用插件。但是手机扫码开发工具预览的时候,ext.json里引用插件就直接报错,插件不存在。所以 这里应该是ext.json 没有覆盖替换 app.json里的

plugins

ext 声明插件报错,appJson可以。因为是第三方平台 所以appid 必填但是必须得是第三方平台的。因此代码片段不能正常运行。除非使用正确 appid 和extAppid


最后一次编辑于  2018-10-30
回答关注问题邀请回答
收藏

4 个回答

  • oric
    oric
    2018-10-29

    extjson暂时不支持配置plugins,开发者工具上面的表现和真机有些差异。

    2018-10-29
    赞同
    回复 8
    • 小玖
      小玖
      2018-10-29

      后续会开放吗

      2018-10-29
      回复
    • oric
      oric
      2018-10-29回复小玖

      后续会开放

      2018-10-29
      回复
    • 小玖
      小玖
      2018-11-06回复oric

      请问大概什么时候可以开放出来

      2018-11-06
      回复
    • Narney
      Narney
      2019-04-03

      什么时候能开放

      2019-04-03
      回复
    • Narney
      Narney
      2019-04-03回复oric

      什么时候能开放

      2019-04-03
      回复
    查看更多(3)
  • 社区技术运营专员-小柿子
    社区技术运营专员-小柿子
    2018-10-24

    ,麻烦重新提供一下

    2018-10-24
    赞同
    回复 10
    • 小玖
      小玖
      2018-10-25

      你好  在我这里用我的第三方平台开发账号的appid开发工具是不会报这个错的,可以用的。但是一用手机扫码调试就报错这错

      2018-10-25
      回复
    • 石头怪
      石头怪
      2018-10-25

      我也遇到过这个问题  在ext.json里面配置plugins选项开发者工具生效  真机调试就会报错   感觉真机对ext.json配置插件的配置不支持

      2018-10-25
      回复
    • 社区技术运营专员-小柿子
      社区技术运营专员-小柿子
      2018-10-25回复小玖

      。查看下配置:https://developers.weixin.qq.com/miniprogram/dev/devtools/projectconfig.html

      2018-10-25
      回复
    • 小玖
      小玖
      2018-10-25回复社区技术运营专员-小柿子

      有点不太明白您的意思,我这里没有进行忽略也不应忽略什么等吧。这里的问题是ext的plugins 没生效  

      2018-10-25
      回复
    • 社区技术运营专员-小柿子
      社区技术运营专员-小柿子
      2018-10-25回复小玖

      https://dldir1.qq.com/WechatWebDev/1.0.0/bb9c1558bb234f98b0a5558bcb629fa8/wechat_devtools_1.02.1810250_x64.exe,试下安装下这个

      2018-10-25
      回复
    查看更多(5)
  • 老郭😄
    老郭😄
    03-09

    我也想知道,什么时候extjson支持plugins字段?目前业务需要这个

    03-09
    赞同
    回复
  • 孤雁
    孤雁
    2019-04-18

    我也想知道,什么时候extjson支持plugins字段?目前业务需要这个

    2019-04-18
    赞同
    回复
登录 后发表内容