收藏
回答

需求:下部导航栏一个tabBar不够用问题?

框架类型 问题类型 终端类型 微信版本 基础库版本
小程序 Bug 微信安卓客户端 1.04.2005122 2.11.1

小程序制作过程中,需要用到,多种身份对应多个tabBar,一个tabBar已经不能满足应用需求,如:客户端、管理端、服务端;

回答关注问题邀请回答
收藏

5 个回答

  • 相
    2020-06-06

    自定义,1、不好看;2、麻烦;3、易出错

    建议微信官方修改支持在json中直接增加就行了,可以限制5个

    2020-06-06
    有用
    回复
  • Creater
    Creater
    2020-06-06

    看下文档,自定义tabbar,满足需求

    2020-06-06
    有用
    回复
  • 俊杰Hiro
    俊杰Hiro
    2020-06-06

    建议自定义底部栏,官方文档里直接提供demo,但是个人觉得体验一般,组件渲染以及实际切换操作时会有卡顿,没有系统默认的流程。

    2020-06-06
    有用
    回复
  • _天马行空_
    _天马行空_
    2020-06-06

    自定义,根据不同权限,显示不同的tabBar

    2020-06-06
    有用
    回复
  • 鹏宇zero
    鹏宇zero
    2020-06-06

    可以尝试使用自定义TableBar组件。

    请参考:

    https://developers.weixin.qq.com/community/develop/article/doc/0002eca26648d08695e9f34bf5bc13?highline=%E8%87%AA%E5%AE%9A%E4%B9%89%20tabbar

    2020-06-06
    有用
    回复 2
    • 相
      2020-06-06
      电脑可以实现,手机提示出错
      runtime.js?devtools_ignore=true:1 Error: module "pages/template/template.js" is not defined
          at require (eval at n.call.document (runtime.js?devtools_ignore=true:1), <anonymous>:2:1970413)
          at eval (eval at n.call.document (runtime.js?devtools_ignore=true:1), <anonymous>:2:1970034)
          at eval (index.js:4)
          at require (eval at n.call.document (runtime.js?devtools_ignore=true:1), <anonymous>:2:1970551)
          at eval (index.js:6)
          at eval (<anonymous>)
          at p (runtime.js?devtools_ignore=true:1)
          at runtime.js?devtools_ignore=true:1
          at k (runtime.js?devtools_ignore=true:1)
          at w (runtime.js?devtools_ignore=true:1)
      ???????
      2020-06-06
      回复
    • 鹏宇zero
      鹏宇zero
      2020-06-06回复
      你检查一下页面路径 和 组件路径有没有写错。
      2020-06-06
      回复
登录 后发表内容
问题标签