收藏
回答

openSetting的caniuse返回false问题

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug wx.canIUse 工具 6.6.6 1.9.98

console.log(wx.canIUse("button.open-type.openSetting"))

上面的代码无论在开发者工具上无论调试基础库是1.9.98还是2.0.8返回的都是false,这样我想要用canIUse做版本未完全替换的过渡阶段做兼容都做不到....请问官方这是bug还是什么情况?

最后一次编辑于  2018-05-24
回答关注问题邀请回答
收藏

2 个回答

  • 王江
    王江
    2018-07-18

    各位朋友,我的

    canIUse

    为什么提示找不到,我在运行时,打断点,wx里面不包含这个属性和函数,

    我的版本库 今天刚修改到2.2.0 ,难道要过一天才行吗?

    2018-07-18
    赞同
    回复
  • 🍉DLY🎉
    🍉DLY🎉
    2018-05-24

    我也遇到了 我的是console.log(wx.canIUse("navigator.app-id")) 无论什么基础库版本都是false,所以我就改用

    wx.getSystemInfoSync()基础库版本判断

    2018-05-24
    赞同
    回复 2
    • ZaKing
      ZaKing
      2018-05-24
      嗯,这种方法可行,但是总感觉不那么对劲
      2018-05-24
      回复
    • 🍉DLY🎉
      🍉DLY🎉
      2018-05-24
      对 这种方式总觉得有点奇怪 但是着急上线 先用着吧 等他们修好了 再改
      2018-05-24
      回复