收藏
回答

自定义组件内如何引用直播插件?

如何在自定义组件内引用直播插件 提供出去给各个分包使用

let livePlayer = requirePlugin('live-player-plugin') 
组件内引用这个的时候报错。

app.json里配置的时候我是把插件放在了index文件目录下。  然后组件引用的时候就会报错,但是好像不支持app.json内配置组件为目录吧


最后一次编辑于  2020-02-21
回答关注问题邀请回答
收藏

2 个回答

  • ꯭悠꯭然꯭
    ꯭悠꯭然꯭
    2020-03-10
    let livePlayer = requirePlugin('live-player-plugin') 必须在
     plugins: {
          "live-player-plugin": {
            version"1.0.2"// 填写该直播组件最新版本号,微信开发者工具调试时可获取最新版本号
            provider"wx2b03c6e691cd7370" // 必须填该直播组件appid,该示例值即为直播组件appid
          }
        },
    
    p配置的分包里面使用吗(就是requirePlugin 必须在 跟配置插件同一个分包才可以使用吗)
    
    2020-03-10
    有用
    回复 1
    • 张学峰
      张学峰
      2020-03-10
      我用起来是这个样子的
      2020-03-10
      回复
  • 灵芝
    灵芝
    2020-02-21

    具体是报什么错呢?

    2020-02-21
    有用
    回复 13
    • 张学峰
      张学峰
      2020-02-21
      2020-02-21
      回复
    • 张学峰
      张学峰
      2020-02-21
      自定义组件内啥代码也还没写,就在最上面写了个引用。  删除那个就不报错了
      2020-02-21
      回复
    • 灵芝
      灵芝
      2020-02-21回复张学峰
      插件appid是不是填写错了,应该是wx2b03c6e691cd7370 这个的
      2020-02-21
      回复
    • 张学峰
      张学峰
      2020-02-21回复灵芝
      没有填错     /0这个是报错的时候给我加上的
      2020-02-21
      回复
    • 灵芝
      灵芝
      2020-02-21回复张学峰
      提供能复现问题的代码片段看下哈(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html
      2020-02-21
      回复
    查看更多(8)
登录 后发表内容
问题标签