收藏
回答

控制台报11 listeners of event AppRoute错误,啥情?

控制台报 VM745:1 [Event] 11 listeners of event AppRoute have been added, possibly causing memory leak.

一进小程序就有这个警告,不知道为什么,

也看了其他人相关的提问,有说更新开发者工具版本的,但是更新之后也还是有警告

我也没用视频组件以及广告插件

官方大大快来帮我解决下,谢谢啦

回答关注问题邀请回答
收藏

8 个回答

  • 社区技术运营专员-小柿子
    社区技术运营专员-小柿子
    2019-08-09

    怎么操作可以复现?新建空的项目试下?

    2019-08-09
    有用
    回复 20
    查看更多(15)
  • 顧問.
    顧問.
    2019-10-29

    详情 - 本地设置 - 调试基础库 改为 “2.8.3” 就行了

    2019-10-29
    有用 6
    回复 3
    • 风吹松林
      风吹松林
      2019-10-29
      就是这样,修改过后就不报错了
      2019-10-29
      1
      回复
    • 6s
      6s
      2019-10-30
      2.9.1又出来了
      2019-10-30
      1
      回复
    • 胡探长
      胡探长
      2019-12-03
      2.94又没了
      2019-12-03
      回复
  • Sunsky
    Sunsky
    2019-08-15

    我也出现这个警告了,小程序开发工具选择基础库版本2.8.0一进入小程序首页后console里边打印的第一条信息就是这个警告。

    2019-08-15
    有用 2
    回复
  • Mr. Yang
    Mr. Yang
    2019-08-31

    我取消“自动运行体验评分”就不再显示了,也不知道是不是因为这个

    2019-08-31
    有用 1
    回复 2
    • Iceberg
      Iceberg
      2019-09-18
      应该就是这个原因,取消自动运行体验评分就没这个警告提示了
      2019-09-18
      回复
    • 以气御码
      以气御码
      04-24
      是这个原因,至于那个版本库不会这样.....
      04-24
      回复
  • Sam
    Sam
    2019-11-13

    2.93版本又不报错了,真是神版本

    2019-11-13
    有用
    回复
  • SONG
    SONG
    2019-10-31

    我也遇到了这个问题,不太理解,期待解决。


    2019-10-31
    有用
    回复
  • Elin
    Elin
    2019-10-30

    我的是2.9.1就报这个错,换成2.9.0也一样报错,修改为2.8.3 就不会报错了。

    2019-10-30
    有用
    回复
  • 筱强
    筱强
    2019-08-26

    基础库选到2.8.0以下好像就没有了,这应该是微信新增的一个日志,但是看不出来怎么用。另一个可能的原因是选择了Audits,希望微信能够增加关于这部分的文档。

    2019-08-26
    有用
    回复 1
    • Josh
      Josh
      2019-08-26
      好的谢谢
      2019-08-26
      回复
登录 后发表内容
问题标签