收藏
回答

swiper bindchange不能触发

问题模块 框架类型 问题类型 API/组件名称 终端类型 操作系统 微信版本 基础库版本
API和组件 小程序 Bug swiper 客户端 iOS 最新版 1.9.93

display-multiple-items 这个参数值为float时,比如1.1 滑动到最后一个swiper-item bindchange方法不触发

最后一次编辑于  2018-03-28  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏关注问题回答

6 个回答

  • Special
    Special
    2018-03-28

    麻烦给个相关的代码片段(https://mp.weixin.qq.com/debug/wxadoc/dev/devtools/minicode.html),我们定位下问题

    2018-03-28
    赞同
    回复
  • 🌊
    🌊
    2018-04-13

    wechatide://minicode/FT8JtEmv6rYg

    2018-04-13
    赞同
    回复
  • 🌊
    🌊
    2018-04-13

    如果打不开的话,你可以自己写一个代码片段。100%必现的,

    2018-04-13
    赞同
    回复
  • 钟海涛
    钟海涛
    2018-04-14

    <swiper  current="{{swiper.current||0}}" bindchange="changeInfo">

    亲测好用  是不是拼写错误了

    2018-04-14
    赞同
    回复
  • 🌊
    🌊
    2018-04-16

    你的参数不对呀。。我的问题是当

    display-multiple-items

    这个参数是float的时候。比如1.2, 1.3这样的,你的例子里面没有设置这个参数。


    2018-04-16
    赞同
    回复
  • 🌊
    🌊
    2018-04-16

    还希望官方能乘早解决这个问题

    Special 官方

    2018-04-16
    赞同
    回复