收藏
回答

button默认样式层级过高

框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
小程序 Bug button 微信iOS客户端 7.0.10(版本无关) 2.8.0版本起

button 的默认样式层级较高,难被覆盖,只有1级class选择器无法覆盖

回答关注问题邀请回答
收藏

1 个回答

  • $
    $
    01-16

    加!important 试试

    01-16
    赞同
    回复 3
    • 涯无凌
      涯无凌
      01-16
      加 !important 是可以解决,但这么高层级的默认样式不应该存在,这种太强制了,而且对于自定义组件来说,加了 !important 反而缺少了用户自定义样式的自由度
      01-16
      回复
    • $
      $
      01-16回复涯无凌
      注意你的class的权重  是可以覆盖的
      01-16
      回复
    • 涯无凌
      涯无凌
      01-16回复$
      肯定可以覆盖,只是觉得加这种高层级的默认样式比较恶心
      01-16
      回复
登录 后发表内容
问题标签