收藏
回答

小程序编辑器编译问题

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows 1.02.1809260

小程序wxml 页面中与js 中相同代码,执行结果不同,请求解答,详见代码片段,页面展示及console.log(输出)



最后一次编辑于  2018-09-27  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

4 个回答

  • nickname
    nickname
    2018-09-29

    可以再详细说明需要反馈的问题吗?没有很明白你的意思,另外你提供的代码片段是乱码的

    2018-09-29
    赞同
    回复 2
    • 小易
      小易
      2018-09-29

      代码片段总是乱码你们是不是应该找找原因啊,为什么开发者开发的没有问题,传上去就总乱码呢?

      2018-09-29
      回复
    • 卢霄霄
      卢霄霄
      2018-09-29

      list有定义在data里,list:[]

      在wxml里的直接写 {{list.indexOf('A')==undefined}}

      界面最终显示的却是 true。。

      2018-09-29
      回复
  • 不悔
    不悔
    2018-09-29

    你们是不是工作量不饱和啊?

    2018-09-29
    赞同
    回复
  • 小易
    小易
    2018-09-29

    wxml {{}} 里面有东西基本都是 true

    2018-09-29
    赞同
    回复 1
    • 卢霄霄
      卢霄霄
      2018-09-29

      小哥你好~ 我是来抬杠的。。。

      {{1==0}}

      2018-09-29
      回复
  • 卢霄霄
    卢霄霄
    2018-09-27

    !=  和 !== 不一样的缘故

    2018-09-27
    赞同
    回复 16
    • Odetta
      Odetta
      2018-09-27

      额(⊙o⊙)…,好像不是这个刚刚截图上的我没注意,改过来之后结果还是不对,我先给你贴两张图吧,代码片段我尽快调出来,不知道为何代码片段,写出来之后分享练级导入,不能正常编译

      2018-09-27
      回复
    • 卢霄霄
      卢霄霄
      2018-09-27回复Odetta

      一点一点看吧。。首先,selfkey 是个数组还是字符串呢?

      2018-09-27
      回复
    • Odetta
      Odetta
      2018-09-27回复卢霄霄

      数组啊,我data里边定义的是  selfkey=[]

      2018-09-27
      回复
    • Odetta
      Odetta
      2018-09-27回复卢霄霄

      我编辑器左右预览处出输出的条件,和ji中congsole.log()里边输出的条件是相同的,第二张截图中我截的全一些输出戴上了行号,可以对应看一下,这个问题很诡异

      2018-09-27
      回复
    • 卢霄霄
      卢霄霄
      2018-09-27回复Odetta

      咦。。你active的样式是啥啊?

      2018-09-27
      回复
    查看更多(11)