收藏
回答

你们正在安卓设备上灰度2.4.0基础库吧?赶紧进来看看吧,出bug了

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug navigator 客户端 6.7.3 2.4.0

安卓设备 并且 2.4.0基础库 并且打开调试模式  使用navigator组件无法跳转小程序,未见异常log(开发版、体验版、线上版表现一致),当关闭调试模式后可以正常跳转。


PS:代码中已经使用navigateToMiniProgramAppIdList的配置方式

回答关注问题邀请回答
收藏

9 个回答

  • 小程序技术专员-SgLy
    小程序技术专员-SgLy
    2018-11-05

    按你说的条件这边测试没有复现,能给一个代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)吗?

    2018-11-05
    赞同
    回复 1
  • &nbsp
    &nbsp
    2018-11-06

    我用wx.navigateToMiniProgram这个方法也不能跳转了  1.努比亚z17安卓6.0.0跳转不提示  直接跳转,可拉取用户信息   2.华为荣耀9青春版 安卓版本8.0.0 基础库版本 2.4 提示是否跳转  但是返回值为fail   3 inphoneX 版本12.0.1   微信版本3.7.3 基础版本2.4 正常跳转  我想知道这个方法到底是怎么用的。。。。。。


    2018-11-06
    赞同 1
    回复 1
  • Yoฉันคิดถึง
    Yoฉันคิดถึง
    2018-11-07

    你是多就没看人家公告了

    2018-11-07
    赞同
    回复 1
    • &nbsp
      &nbsp
      2018-11-07

      大佬啥公告

      2018-11-07
      回复
  • 李伟光
    李伟光
    2018-11-07

    使用wx.navigateToMiniProgram,在app.json里也配置了小程序列表,开发版本可以正常跳转,线上版本提示该功能无法使用。苹果和安卓都是这样,跳转小程序还是关联在同一个公众号下的。有人来解答一下吗?

    "navigateToMiniProgramAppIdList": [

    ]




    2018-11-07
    赞同
    回复
  • 田振海
    田振海
    2018-11-06

    需要在app.json里配置小程序列表

    "navigateToMiniProgramAppIdList": [

    ]

    https://developers.weixin.qq.com/miniprogram/dev/framework/config.html

    2018-11-06
    赞同
    回复
  • Lee
    Lee
    2018-11-06

    我靠,我不得不吐槽一下,昨天我们线上部分用户一直报不能跳转。找了好几个机子都复现不了,然后突然某一台机子必现,还以为是机型兼容问题。结果比对了版本库才知道有的机型已经是2.4.0了,猝不及防。

    2018-11-06
    赞同
    回复 8
    • well
      well
      2018-11-06

      你是线上版才能跳吗

      2018-11-06
      回复
    • Lee
      Lee
      2018-11-07回复well

      开发版,体验版正常跳,就是线上版跳不了。弹窗都没有。

      2018-11-07
      回复
    • 鱼星草
      鱼星草
      2018-11-07回复Lee

      解决了吗,我遇到了同样的问题

      2018-11-07
      回复
    • Lee
      Lee
      2018-11-07回复鱼星草

      加白名单

      2018-11-07
      回复
    • 鱼星草
      鱼星草
      2018-11-07回复Lee

      加了,还不行,更新了下编辑器就可以了

      2018-11-07
      回复
    查看更多(3)
  • 🐠糖醋鱼
    🐠糖醋鱼
    2018-11-05

    灰度测试.......

    2018-11-05
    赞同
    回复 1
  • 拾忆
    拾忆
    2018-11-05

    2.4.0还没见到

    2018-11-05
    赞同
    回复 1
    • 张博 Bill
      张博 Bill
      2018-11-05

      嗯,在灰度测试,部分安卓机已经升级到2.4了,ios的还没见到

      2018-11-05
      回复
  • @🐲较瘦
    @🐲较瘦
    2018-11-05

    我用的开发工具最新的基础库才2.3.2

    2018-11-05
    赞同
    回复 4
    • 张博 Bill
      张博 Bill
      2018-11-05

      每次都是客户端全量覆盖了才出开发工具的

      2018-11-05
      回复
    • @🐲较瘦
      @🐲较瘦
      2018-11-05回复张博 Bill

      那怎么才能看到客户端对应的基础库呐?

      2018-11-05
      回复
    • 张博 Bill
      张博 Bill
      2018-11-05回复@🐲较瘦

      打开“调试模式”,点击页面里的绿色按钮“vConsole”,在System那个tab栏里,仔细找可以找到基础库版本号


      2018-11-05
      回复
    • @🐲较瘦
      @🐲较瘦
      2018-11-05回复张博 Bill

      好的呐,感谢

      2018-11-05
      回复
登录 后发表内容