收藏
回答

真机调试报 eval script evaluate_id #20 failed TypeError

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug macOS 1.02.1912272

开发者工具没有问题,真机调试必现,ios 和安卓都会必现


回答关注问题邀请回答
收藏

3 个回答

  • Albert Einstein
    Albert Einstein
    2019-12-31

    这个 npm 模块是否通过工具 - 编译 npm 模块进行编译处理?

    2019-12-31
    赞同
    回复 11
    • Marvin 💡
      Marvin 💡
      2019-12-31
      没有,自己打包引入的项目的
      2019-12-31
      回复
    • Albert Einstein
      Albert Einstein
      2019-12-31回复Marvin 💡
      require 的时候是直接 require 这个模块名,还是全具体路径 require('./node_modules/core-js...') 呢?
      2019-12-31
      回复
    • Marvin 💡
      Marvin 💡
      2019-12-31
      你的意思是这个错误是项目中的 runtime.js 报出的?
      2019-12-31
      回复
    • Marvin 💡
      Marvin 💡
      2019-12-31回复Albert Einstein
      打包后的代码 `var validate = __webpack_require__(/*! ./_validate-collection */ "./node_modules/core-js/modules/_validate-collection.js");`
      2019-12-31
      回复
    • Marvin 💡
      Marvin 💡
      2019-12-31
      我是通过 webpack 将使用的第三方包打包成一个 lib , 项目中在引入
      2019-12-31
      回复
    查看更多(6)
  • 杭州弧途科技有限公司
    杭州弧途科技有限公司
    2019-12-31

    使用 稳定版的开发者工具重试下。

    2019-12-31
    赞同
    回复 1
    • Marvin 💡
      Marvin 💡
      2019-12-31
      装了稳定版本,同样有这个问题
      2019-12-31
      回复
  • Marvin 💡
    Marvin 💡
    2019-12-31

    以前的代码是没问题,项目增加了消息订阅功能,怀疑跟这个 wx.requestSubscribeMessage api 有关

    2019-12-31
    赞同
    回复
登录 后发表内容
问题标签