收藏
回答

[插件热更新] 同一个小程序用同一个appid的插件不支持热更新?

问题类型 插件 AppID 插件版本号 AppID 微信版本 基础库版本
Bug wxb3959dd9f45a8c2d 0.6.1 wxb3959dd9f45a8c2d 7.0.2 2.4.4

小程序引用同样一个appid的插件,不支持热更新?

回答关注问题邀请回答
收藏

2 个回答

  • 灵芝
    灵芝
    2019-01-10

    同一个APPID是什么意思?

    2019-01-10
    有用
    回复 8
    • NaiCco
      NaiCco
      2019-01-10

      就是说我的小程序appid是123456,我用这个账号同时开通了一个插件,开发插件,那我上线的这个插件的appid也是123456.

      我在appid为123456的这个小程序内引用appid为123456的插件。

      昨天试了一下热更新,插件版本从0.6.0更新到0.6.1,收到提示可以热更新,但是每次都失败。

      2019-01-10
      回复
    • oric
      oric
      2019-01-14回复NaiCco

      给一下这些信息,我们看一下1.更新失败的小程序appid

      2.插件的appid

      3.具体是在哪一步失败的,提示信息是什么


      2019-01-14
      回复
    • NaiCco
      NaiCco
      2019-01-15回复oric

      小程序appid:

      wxb3959dd9f45a8c2d

      插件appid:

      wxb3959dd9f45a8c2d

      在微信端收到推送,点击消息卡片直接提示更新失败。


      2019-01-15
      回复
    • oric
      oric
      2019-01-15回复NaiCco

      麻烦再触发一下,给一下时间,我查一下日志

      2019-01-15
      回复
    • NaiCco
      NaiCco
      2019-01-15回复oric

      我们已经手动升级过版本了。只能等下一版本了。

      2019-01-15
      回复
    查看更多(3)
  • 宁波一倍网络科技有限公司
    宁波一倍网络科技有限公司
    2019-01-10

    热更新?插件更新了不仅仅只是在app.json里改个版本号那么简单,得了解新版本插件的接口有没有变化,万一人家插件更新改过了接口,你还用老的接口当然用不了.

    2019-01-10
    有用
    回复
登录 后发表内容