收藏
回答

可以强制使用某一个低版本的基础库吗?

现在通知设置-基础库最低版本可以指定小程序支持的最低版本,但是我想要我的程序,仅仅支持某一个低版本的基础库,高版本的我不想支持!需要排查某一个高版本的问题!怎么办?

回答关注问题邀请回答
收藏

3 个回答

  • 灵芝
    灵芝
    2019-12-16

    你好,暂不支持此功能,可以使用低版本的机型测试

    2019-12-16
    有用
    回复 10
    • 陈鹏升
      陈鹏升
      2019-12-16
      但是我用了一台超级老的机器,android6.0的,基础库仍然是2.9.4。版本降都降不了。
      2019-12-16
      回复
    • 灵芝
      灵芝
      2019-12-16回复陈鹏升
      基础库是跟微信版本相关的:https://developers.weixin.qq.com/miniprogram/dev/framework/client-lib/version.html
      2019-12-16
      回复
    • 陈鹏升
      陈鹏升
      2019-12-16回复灵芝
      咦,这个上面。我看的话,不是基础库和安卓版本相关么,好像不是微信版本哦。比如,第一行。基础库版本2.9.4,安卓版本是7.07
      2019-12-16
      回复
    • 灵芝
      灵芝
      2019-12-16回复陈鹏升
      是微信版本哈
      2019-12-16
      回复
    • 陈鹏升
      陈鹏升
      2019-12-16
      好的,我试试
      2019-12-16
      回复
    查看更多(5)
  • 老张
    老张
    2019-12-14

    可以。小程序开发工具里配置基础库指定你要的版本就行。

    2019-12-14
    有用
    回复 3
    • 陈鹏升
      陈鹏升
      2019-12-14
      是libVersion么?模拟器里面通过getSystemInfoSync打出来的sdkVersion确实和这个libVersion一致。但是真机上面就不是了哦。
      2019-12-14
      回复
    • 老张
      老张
      2019-12-14回复陈鹏升
      开发工具--详情--本地设置--调试基础库
      2019-12-14
      回复
    • 陈鹏升
      陈鹏升
      2019-12-14
      更改这个后的效果和project.config.json中更改libVersion的效果一致。调试环境下的基础库版本确实变了,但是真机调试时不变的。比如你这里设置了2.9.2的话,我自己的华为mate20上面,通过log,getSystemInfoSync打出来。仍然是2.9.4
      2019-12-14
      回复
  • 陈鹏升
    陈鹏升
    2019-12-14

    svg的颜色fill失效,我想要排查是否是由于小程序的基础库导致的。但是我没办法切换回低版本的基础库诶。也不清楚原来用的基础库的版本。

    2019-12-14
    有用
    回复
登录 后发表内容
问题标签