收藏
回答

"request:fail 发生了 SSL 错误无法建立与该服务器的安全连接。"

"request:fail 发生了 SSL 错误,无法建立与该服务器的安全连接。"


android机子可以真机预览,ios机子报这个错误

最后一次编辑于  2018-04-03
回答关注问题邀请回答
收藏

10 个回答

  • 璐见不贫
    璐见不贫
    2018-04-24

    先用https://www.qcloud.com/product/ssl.html#userDefined10 测试一下是不是证书的问题,我们就是证书问题

    2018-04-24
    赞同 1
    回复 1
    • 键盘上的手艺人
      键盘上的手艺人
      2019-08-08
      这个链接是腾讯云的SSL购买页面啊,怎么校验
      2019-08-08
      1
      回复
  • 小三爷
    小三爷
    2018-04-20

    主要是因为使用的sever2008  IIS7 默认使用的SSL2.0,而iOS微信需要使用TLS 1.2。

    只要修改一下,启用server 2008 的TLS 1.2就可以了。

    http://www.simapple.com/418.html

    2018-04-20
    赞同 1
    回复
  • Lucas
    Lucas
    2019-07-02

    IIS服务器 ,更换支持的证书,有免费的也有收费的,下载证书然后倒入

    然后新建一个.reg 的文件 例如新建一个  lucas_andot.reg文件,把下面代码黏贴进去,双击管理员执行就可以了,完美解决

    Windows Registry Editor Version 5.00
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols]
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0]
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0\Client]
     
    "DisabledByDefault"=dword:00000000
     
    "Enabled"=dword:00000000
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2]
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]
     
    "DisabledByDefault"=dword:00000000
     
    "Enabled"=dword:00000001
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Server]
     
    "DisabledByDefault"=dword:00000000
     
    "Enabled"=dword:00000001
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1]
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client]
     
    "DisabledByDefault"=dword:00000000
     
    "Enabled"=dword:00000001
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Server]
     
    "DisabledByDefault"=dword:00000000
     
    "Enabled"=dword:00000001


    2019-07-02
    赞同
    回复
  • 钱长红
    钱长红
    2018-05-23

    楼主解决了吗

    2018-05-23
    赞同
    回复
  • 杨鹏👍
    杨鹏👍
    2018-04-24

    刚看到评论,谢谢楼上的兄弟!

    2018-04-24
    赞同
    回复
  • 杨鹏👍
    杨鹏👍
    2018-04-24

    终于找到解决方法啦! 这个是正解:http://www.jb51.net/article/99159.htm

    只要在PowerShell里面运行一下就行,重启机器!

    2018-04-24
    赞同
    回复
  • 杨鹏👍
    杨鹏👍
    2018-04-24
    兄弟,我按照你提供的链接操作了,可还是不行,请帮我解决一下!谢谢
    2018-04-24
    赞同
    回复
  • 璐见不贫
    璐见不贫
    2018-04-19

    楼主解决了吗?我也遇到同样问题

    2018-04-19
    赞同
    回复
  • 小三爷
    小三爷
    2018-04-08

    还没解决


    2018-04-08
    赞同
    回复
  • 这都申请了
    这都申请了
    2018-04-03

    我也出现这个问题了,是tls的问题吗?

    2018-04-03
    赞同
    回复
登录 后发表内容