收藏
回答

微信小程序网络请求支持Android5.0以下吗

框架类型 问题类型 API/组件名称 终端类型 操作系统 微信版本 基础库版本
小程序 需求 wx.request() 客户端 Android 6.6.6 1.4.0

- 需求的场景描述(希望解决的问题)

如题:微信小程序网络请求支持Android5.0以下吗,目前android只支持tls1.1或者1.0版本网络请求,但是wx.request()只支持tls1.2是吗?所以推测微信小程序不支持android5.0以下版本手机,对吗?


- 希望提供的能力


希望官方解答


回答关注问题邀请回答
收藏

5 个回答

  • 小程序运营专员 - cunjin
    小程序运营专员 - cunjin
    2018-05-10

    支持

    2018-05-10
    有用
    回复
  • 小程序运营专员 - cunjin
    小程序运营专员 - cunjin
    2018-05-10

    android5.0以下的版本都可以发送request请求,只是你的https服务器需要支持tls1.2以及以下的版本

    2018-05-10
    有用
    回复 1
    • 🇿 .🇵
      🇿 .🇵
      2019-10-25
      你好,如果小程序用到了腾讯地图位置服务,在小程序后台合法域名里面配置了https://apis.map.qq.com这个,请问腾讯的地图https服务器支持tls1.2以及以下的版本吗?
      2019-10-25
      回复
  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    2018-05-08

    你好,小程序支持Android5.0以下版本手机的


    2018-05-08
    有用
    回复 1
    • 🇿 .🇵
      🇿 .🇵
      2019-10-25
      你好,如果小程序用到了腾讯地图位置服务,在小程序后台合法域名里面配置了https://apis.map.qq.com这个,请问腾讯的地图https服务器支持tls1.2以及以下的版本吗?
      2019-10-25
      回复
  • 等风来
    等风来
    2018-05-10

    谢谢您cunjinli,我想确认下,wx.request()这个API支持https服务器的tls1.1或tls1.0以下请求吗?

    2018-05-10
    有用
    回复
  • 等风来
    等风来
    2018-05-08

    谢谢您的回复,但是据官方给出的API(wx.request)只能支持tls1.2版本,那么这不是互相矛盾吗?部分旧机型还未支持tls1.2(也就是部分android5.0以下版本手机)需要用到tls1.2以下版本,而API只能用TLS1.2版本,这个不矛盾吗?

    2018-05-08
    有用
    回复 1
    • 🇿 .🇵
      🇿 .🇵
      2019-10-24
      是很矛盾。可否同时配置2个,兼容2个可以吗?tsl1.2和tsl1.1
      2019-10-24
      回复
登录 后发表内容