收藏
回答

【已结帖】严重怀疑开发者工具在某种情况下依然会丢失样式或无法彻底清除缓存的bug

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows v1.02.1811150

============模拟器部分样式丢失,真机上正常且不报错的问题已解决,见:https://developers.weixin.qq.com/community/develop/doc/000ec6f8ccc0e83fb9a788dbb56c00





============








前几天的帖子:https://developers.weixin.qq.com/community/develop/doc/000ec6f8ccc0e83fb9a788dbb56c00?jumpto=comment&commentid=00040e6391c13040c5a71c4e5560


怀疑缓存问题复现方法一:

先定义一个组件,名为:item-touch-left,里面是4个文件先写好【保证可以正常运行】,注意现在是可以正常运行且不报错的!

接着再创建一个组件,名为:item-touch-left-bug,把刚才的item-touch-left里面的文件直接复制到新的item-touch-left-bug中,如图:


然后在主页面调用的地方把原来的

"item-touch-left": "/components/item-touch-left/index"

修改成:

"item-touch-left": "/components/item-touch-left-bug/index"

如图:


按理说,item-touch-left是好的,item-touch-left-bug应该也可以运行的,但是!!!神奇的事情出现了!item-touch-left-bug运行后竟然报错了!!!当我点击工具上的【全部清除】缓存后这个报错依然存在!

然后我就点了右上角的x关闭了工具,再次打开时我惊呆了,上周五提到的那个样式丢失的问题重现了!如图:

此时我已经猜到真机上是正常的,为了验证,特意再生成后扫了一下,果然!如图:



=====我敢跟管理员赌上一个鸡腿,证明小程序开发者工具有问题!

我已经被【缓存无法彻底清除】和这种【样式在模拟器上丢失】的问题浪费掉了不少时间,你们要负责(:哭)

最后一次编辑于  2018-11-20  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

2 个回答

  • 流年
    流年
    2018-11-20

    官方不回复就算了,自己发现的坑自己来填!

    又瞎折腾了几个小时,目前坑已解决,我已经有90%的把握下次再遇到这种【模拟器中样式丢失,而真机调试却正常并且不报任何错】问题时可以自救。靠官方解决问题,不可能的,这辈子都不可能的了!

    2018-11-20
    赞同
    回复 1
    • 娇华
      娇华
      2018-11-20

      这里是我们的官方人员哈

      2018-11-20
      回复
  • 夏洛埃克
    夏洛埃克
    2018-11-19


    根据你的修改,

    "item-touch-left""/components/item-touch-left/index"

    修改成:

    "item-touch-left""/components/item-touch-left-bug/index"

    并没有复现

    你可以提供下代码片段吗?

    2018-11-19
    赞同
    回复