收藏
回答

wx.getUserProfile无效而且是线上?安卓报错100%且基础版本库未2.13。@官方大佬

回答关注问题邀请回答
收藏

2 个回答

  • 爆矮
    爆矮
    03-17

    用if(wx.getUserProfile)判断吧 版本号判断不准 2.11也有的不支持

    03-17
    有用 1
    回复 16
    • Brother斌🎈
      Brother斌🎈
      03-17
      大佬你们项目改成getUserProfile的版本上线了吗,有没有什么坑分享一下
      03-17
      回复
    • 清茶涩
      清茶涩
      03-17
      嗯,发一个紧急版本算了。微信老坑比
      03-17
      回复
    • 清茶涩
      清茶涩
      03-17回复Brother斌🎈
      我这就是上线了发现的坑了,文档写着2.10以上支持,一堆用户2.13都报错。微信老坑比
      03-17
      回复
    • 爆矮
      爆矮
      03-17回复Brother斌🎈
      我上线了,现在小程序只要销毁之后在进入就得授权,后端还没做授权控制
      03-17
      回复
    • Brother斌🎈
      Brother斌🎈
      03-17
      那我还是再等等吧
      03-17
      回复
    查看更多(11)
  • |G.XIAO|
    |G.XIAO|
    03-17

    低版本基础库不支持,需要加判断

    03-17
    有用
    回复 5
    • 清茶涩
      清茶涩
      03-17
      对呀,基础库2.10.4版开始支持,用户都是2.13.0了,难道不是2.10.4开始???
      03-17
      回复
    • |G.XIAO|
      |G.XIAO|
      03-17回复清茶涩
      我看了一下基础库日志,还是兼容一下吧
      03-17
      回复
    • Z
      Z
      03-17回复清茶涩
      似乎这几个支持。
      03-17
      回复
    • 清茶涩
      清茶涩
      03-17回复|G.XIAO|
      凉了呀,这都上线了,看来要发一个紧急版本了
      03-17
      回复
    • |G.XIAO|
      |G.XIAO|
      03-17回复清茶涩
      加油
      03-17
      回复
登录 后发表内容
问题标签