收藏
回答

请问小程序基础库版本和系统版本有关系吗?

微信后台我们将小程序基础库版本设置成了2.9.3,之所以设置成这个版本,是因为我们项目里面用到了简易双向绑定 https://developers.weixin.qq.com/miniprogram/dev/framework/view/two-way-bindings.html,但现在问题来了,部分IOS用户给我们反馈,打开小程序提示微信版本过低,前去升级,可是跳转到appStore,又提示已经是最新版微信 了,目前收集到的类似问题,微信版本已经是7.0.13,7.0.14,请问小程序基础库版本除了和微信版本有关,是不是和手机系统版本也有关系?但官方文档并没有提及基础库版本和系统版本有关,请各位大神指教,谢谢。

回答关注问题邀请回答
收藏

2 个回答

  • Distance
    Distance
    07-29

    你好请参考:https://developers.weixin.qq.com/miniprogram/dev/framework/client-lib/version.html

    07-29
    有用
    回复 3
    • 王立建
      王立建
      07-29
      你好,感谢您的回复,但是该文档上只写了基础库版本 和 对应安卓、IOS上的微信版本的对应关系,并没有写出基础库版本和安卓系统版本或者IOS系统版本有什么直接关系呢
      07-29
      回复
    • Distance
      Distance
      07-29回复王立建
      首先基础库版本只跟微信版本有关,只有像深色模式这样的API是需要手机支持,所以才跟手机系统有关。另外,虽然简易双向绑定标记的是基础库2.9.3开始支持,但更新文档中标记了小程序框架在v2.12.0支持双向绑定,应该以最新这个为准。
      07-29
      1
      回复
    • 王立建
      王立建
      07-29回复Distance
      既然基础库版本只跟微信版本有关,那为什么用户的微信版本已经升级到了最新,再次打开打开小程序,依然提示用户微信版本过低呢?感谢您的回答
      07-29
      回复
  • 冰箱
    冰箱
    07-29

    有关系

    07-29
    有用
    回复
登录 后发表内容
问题标签