收藏
回答

关于小程序使用npm的一些问题

问题模块 框架类型 问题类型 终端类型 微信版本 基础库版本
框架 小程序 Bug 工具 1.02.1810250 2.3.2

- 当前 Bug 的表现(可附上截图)

官方文档要求使用小程序 npm 包的特性的时候,需要将对应的小程序 npm 包安装到对应的 dependencies 字段中,但是试验了一下,假设现在有一个完全纯粹不依赖其他包的小程序 npm 包,简称A,另外因为小程序项目本身会有一些打包前的构建和编译,利用gulp实现,所以在 devDependencies 字段中会有 gulp 这种依赖。最后在开发者工具中的工具栏里选择“构建npm”,发现A正常构建到miniprogram-npm目录下,gulp虽然没有构建进去,但是 gulp 这个包下面声明的一些 dependencies 包被构建进去。请问这是 feature 还是 bug?


- 预期表现

A应该正常构建,gulp 及其依赖任何包(dependencies & devDependencies)都不应该构建进去。


- 复现路径


- 提供一个最简复现 Demo


最后一次编辑于  2018-11-05  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

1 个回答

  • June
    June
    2018-11-05

    原先的实现是 node_modules 里的所有包都会被构建。


    后续会调整成根据 package.json 的 dependencies 字段构建的方式,会跟近期工具 release 版本发布。

    2018-11-05
    赞同
    回复