收藏
回答

今天微信给我们公司小程序发公测了,小程序直播组件接入,我按指南操作,报错?

使用方法说明

1. 在分包内引入直播组件代码包,项目根目录的 app.json 引用如下

{
  "subpackages": [
    {
      "root": "packageA",
      "pages": [
        "pages/home/home"
      ],
      "plugins": {
        "live-player-plugin": {
          "version": "1.0.0", // 填写该直播组件版本号
          "provider": "wx2b03c6e691cd7370" // 必须填该直播组件appid
        }
      }
    }
  ]
}

2. 组件页面使用

第一步配置添加之后即可直接通过链接地址跳转到直播组件页面,其中链接地址带上直播房间id,可通过我们提供的api接口获取(详见第6节【拉取直播房间列表api接口使用】)。

<navigator url="plugin-private://wx2b03c6e691cd7370/pages/live-player-plugin?room_id=[直播房间id]">
  Go to Live Player Plugin page
</navigator>

通过该链接可跳转到直播组件页面(当前页面入口仅开放‘live-player-plugin’)。

-----------------------

我按上面方法操作,报下面的错误:

undefined

Expecting 'STRING', got INVALID ,请问是什么错误?

回答关注问题邀请回答
收藏

11 个回答

  • 小程序技术专员-binnie
    小程序技术专员-binnie
    2020-02-17

    你好,麻烦提供能复现问题的简单代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)。

    2020-02-17
    有用
    回复 9
    • 文龙
      文龙
      2020-02-20
      provider:wx2**********5, version:1.0.0, 插件版本不存在,the version of the app/plugin is not exist
      Error: provider:wx2**********5, version:1.0.0, 插件版本不存在,the version of the app/plugin is not exist
          at C:\Users\ckjy\AppData\Local\微信开发者工具\User Data\WeappCode\package.nw\core.wxvpkg\****eaa.js:1:1315
          at processTicksAndRejections (internal/process/task_queues.js:86:5)
      2020-02-20
      回复
    • 小程序技术专员-binnie
      小程序技术专员-binnie
      2020-02-20回复文龙
      appid错了,麻烦看下mp上的接入文档
      2020-02-20
      回复
    • 文龙
      文龙
      2020-02-20
      provider:wx2911548a18ed7d95, version:1.0.0, 插件版本不存在,the version of the app/plugin is not exist
      Error: provider:wx2911548a18ed7d95, version:1.0.0, 插件版本不存在,the version of the app/plugin is not exist
          at C:\Users\ckjy\AppData\Local\微信开发者工具\User Data\WeappCode\package.nw\core.wxvpkg\2d8c17f8789be1869edbd369314f5eaa.js:1:1315
          at processTicksAndRejections (internal/process/task_queues.js:86:5)


      我回复提示有敏感信息,我就把第一次发的上面的appid改成*了。
      2020-02-20
      回复
    • 追光者
      追光者
      2020-02-24回复文龙
      我也遇到相同的提示请问怎么解决的?
      2020-02-24
      回复
    • 文龙
      文龙
      2020-02-24回复追光者
      按文档的代码复制就行,不需要把appid换成自己的
      2020-02-24
      回复
    查看更多(4)
  • 陈宇明
    陈宇明
    2020-02-17

    看下是不是需要调整到指定代码库版本

    2020-02-17
    有用 2
    回复 1
    • 文龙
      文龙
      2020-02-19
      现在的基础库是2.10.1最新的
      2020-02-19
      回复
  • 飞鸟
    飞鸟
    2020-03-03

    我是个新手,所以昨天也遇到同样的问题。但是后来自己检查解决了。

    报错那句话的意思是说,代码里有不应该出现的符号。

    官方给的示例,是没有问题的。只要要结合app.json现有代码的格式,把官方给的代码拆成两段放进去。

    第一段代码就是:


        {
          "root": "packageA",
          "pages": [
            "pages/home/home"
          ]
        }
    
    


    要把这段代码和其他的这种格式的代码并列,中间加个半角逗号。


    另外一部分就是plugins那一段,这个本来app.json里已经有这个函数了,只需要把下面代码加到plugins函数里面,和现有的变量用半角都好分开即可。我测试的时候,似乎必须把后面的注释说明去掉,否则会报错。


    你看下我发的图。



    


    2020-03-03
    有用 1
    回复 3
    • rmy
      rmy
      2020-03-03
      我这样写的没问题,编译后插件怎么不在项目中?
      2020-03-03
      回复
    • 飞鸟
      飞鸟
      2020-03-03回复rmy
      插件不需要再项目中啊   直接从微信服务器调用   要不然那个provider就没有实际作用了
      2020-03-03
      回复
    • rmy
      rmy
      2020-03-03
      那我的https://wxaliveplay.weixin.qq.com/报404
      2020-03-03
      回复
  • 德维波尔国际贸易进口商
    德维波尔国际贸易进口商
    2020-03-03

    微信小程序直播 V号 : deweiboer 获得邀请的有用,没获邀请的暂时不支持

    2020-03-03
    有用 1
    回复
  • peng
    peng
    2020-02-20

    app.json中不要有注释

    2020-02-20
    有用 1
    回复 1
    • 文龙
      文龙
      2020-02-20
      谢谢。
      2020-02-20
      回复
  • 。
    2020-03-16

    2020-03-16
    有用
    回复
  • 靳民涛
    靳民涛
    2020-03-12

    小程序分包怎么下载

    2020-03-12
    有用
    回复
  • MR.ZHAO
    MR.ZHAO
    2020-03-02

    直播给了体验 , 没有live-player组件也能播么?

    2020-03-02
    有用
    回复 1
    • 文龙
      文龙
      2020-03-02
      试试就知道
      2020-03-02
      回复
  • 卡业连萌℡16216444444
    卡业连萌℡16216444444
    2020-02-27

    加微信聊聊小程序直播15588698698

    2020-02-27
    有用
    回复
  • +2
    +2
    2020-02-22
    跳转链接写 plugin-private://wx2b03c6e691cd7370/pages/live-player-plugin?room_id=[直播房间id] 跳转不了 是不是我的路径有问题?其它的配置跟官方文档上一样
    


    2020-02-22
    有用
    回复 6
    • 文龙
      文龙
      2020-02-24
      2020-02-24
      1
      回复
    • 文龙
      文龙
      2020-02-24
      能正常跳转
      2020-02-24
      回复
    • +2
      +2
      2020-02-24回复文龙
      我找到原因了 appid要填插件的appid。。。。
      2020-02-24
      回复
    • Daisy
      Daisy
      2020-02-25
      更新以下插件版本就好了,1.0.1
      2020-02-25
      回复
    • joanna
      joanna
      2020-02-28回复+2
      我的也不跳转
      2020-02-28
      回复
    查看更多(1)

正在加载...

登录 后发表内容
问题标签