收藏
回答

setTabBarBadge在不同基础库下会出现不一样的错误判断?

图1 2.10.2版本及以上会报错


图2 2.10.1版本无报错


图3 使用相关函数的地方



所用api是wx.setTabBarBadge,上图搜索的函数封装了此api和其他相关数据改动

回答关注问题邀请回答
收藏

3 个回答

  • 万浩
    万浩
    2020-04-09

    请问一下这个最后是如何处理的?

    2020-04-09
    有用
    回复 1
    • 塑料大棚
      塑料大棚
      2020-04-09
      官方库更新了几个版本自己就好了
      2020-04-09
      回复
  • 社区技术运营专员-灵芝
    社区技术运营专员-灵芝
    2020-03-26

    你好,麻烦提供能复现问题的代码片段看下(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html

    2020-03-26
    有用
    回复 5
  • 厂危,速归。
    厂危,速归。
    2020-03-26

    app.js里会报这个错。有tabbar页面则不会。

    2020-03-26
    有用
    回复 2
    • 塑料大棚
      塑料大棚
      2020-03-26
      app.js里没有使用函数,调用都是在tabbar调用的这样也不行啊...
      2020-03-26
      回复
    • 厂危,速归。
      厂危,速归。
      2020-03-26回复塑料大棚
      不会呀。我这在app.js调用 会报错。以前我们都是这样的。那天调试另外个问题打开vonsole看到有这个报错了。。
      2020-03-26
      回复
登录 后发表内容
问题标签