收藏
回答

'import' 'require'不支持绝对路径吗?

问题模块 框架类型 问题类型 终端类型 微信版本 基础库版本
框架 小程序 Bug 工具 6.7.3 2.4.2

import utt_im from "/utils/utils"

const utt_re = require('../../utils/utils')


相对路径无效,会自动拼接在当前路径下,有解决方法吗?

最后一次编辑于  2018-12-19  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

1 个回答

  • 半寸灰
    半寸灰
    2018-12-19

    只能相对路径


    点开头  就是 拼接 当前目录

    两点开头  第一次听说路径会拼接  当前目录  ,这个起码  应该拼接上一级目录


    2018-12-19
    赞同
    回复 5
    • 黑黑
      黑黑
      2018-12-19

      `/`    从根路径拼接

      `./'    当前目录

      `../'    父级目录

      这些都知道的,小程序好像不支持`/`,`./`没试,`../`支持

      2018-12-19
      回复
    • 半寸灰
      半寸灰
      2018-12-19回复黑黑

      我一直在用  是支持的

      2018-12-19
      回复
    • 半寸灰
      半寸灰
      2018-12-19回复黑黑

      不支持 /开头的  也就是 根

      2018-12-19
      1
      回复
    • 半寸灰
      半寸灰
      2018-12-19回复黑黑

      /开头的 也是拼接 当前目录

      2018-12-19
      1
      回复
    • 黑黑
      黑黑
      2018-12-19回复半寸灰

      感谢

      2018-12-19
      回复