收藏
回答

functional-page has not been declared

框架类型 问题类型 终端类型 微信版本 基础库版本
小程序 Bug 客户端 6.6.5, 6.6.0 未知

Error: APP-SERVICE-Engine:__wx__/functional-page has not been declared in app.json. 运维中心从 2018-11-9 突然出现这个类型的错误。而功能页在这之前很早就启用了,functionalPages: true。 问题:


1. 这个错误是否会导致小程序白屏?  

最后一次编辑于  2018-11-13
回答关注问题邀请回答
收藏

4 个回答

  • oric
    oric
    2018-11-12

    提供下appid

    2018-11-12
    有用
    回复 4
    • yan
      yan
      2018-11-12

      wx01bb1ef166cd3f4e

      2018-11-12
      回复
    • 小程序技术专员-LastLeaf
      小程序技术专员-LastLeaf
      2018-11-12回复yan

      已经基本查明原因。请问有报错来自 6.7.0 及以上的微信版本吗?

      2018-11-12
      回复
    • royslg
      royslg
      2018-11-12


      同样一个问题,最近出现很多这个问题。我的手机基础库版本是2.0.9。


      2018-11-12
      回复
    • yan
      yan
      2018-11-12回复小程序技术专员-LastLeaf

      目前只看到 6.6.5 和 6.6.0

      2018-11-12
      回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2018-11-12

    请问所有者小程序有版本更新吗?

    2018-11-12
    有用
    回复
  • royslg
    royslg
    2018-11-13

    我的问题找到了,是app.json “functionalPages”字段的影响,这个字段值为true和false都会出现这个错。索性去掉,解决问题。

    这个字段的基础库版本要求是2.1.0 ;我的手机正好是2.0.9

    2018-11-13
    有用
    回复 1
  • 兰昊
    兰昊
    2018-11-12

    看文档了吗,文档上是不是没说清楚啊?

    2018-11-12
    有用
    回复
登录 后发表内容