收藏
回答

wx.getUserProfile 报错?!

真机,基础 2.15.0,wx.getUserProfile 报错无法执行!!!

让我们适配,API 却不能执行,这什么鬼啊!!!😭

wx.getUserProfile({
  desc: '声明获取用户个人信息后的用途',
  success: pfres => {
    console.log('getUserProfile', pfres)
  }
})



回答关注问题邀请回答
收藏

8 个回答

  • 社区技术运营专员-壹君
    社区技术运营专员-壹君
    04-01

    这边测试并没有报错,

    https://developers.weixin.qq.com/miniprogram/dev/api/open-api/user-info/wx.getUserProfile.html文档有代码示例,可以参考看看

    04-01
    有用
    回复 3
    • zdede
      zdede
      04-16
      真机不行,不是开发工具
      04-16
      回复
    • Unpredictable*
      Unpredictable*
      04-26
      真机告警
      04-26
      回复
    • Unpredictable*
      Unpredictable*
      04-26回复Unpredictable*
      真机告警。wx.getUserProfile is not function 。开发工具没报错
      04-26
      回复
  • 闰先生
    闰先生
    03-19

    我微信版本库2.10.4 以上(除了2.13.0)其他都可以开发者工具(1.05.2103172

    )唤醒,手机(iOS14 8.0.2)除了2.16.0全部报错

    wx.getUserProfile is not a function

    TypeError: wx.getUserProfile is not a function

    03-19
    有用 1
    回复 1
    • zdede
      zdede
      04-16
      真机没反应
      04-16
      回复
  • dk
    dk
    03-05

    还是不行呀,微信8.0.2/基础库2.15.0 真机调试不行,2021-3-5 12:00。

    你们的可以了么?

    03-05
    有用 1
    回复
  • 默
    03-02

    怎么说呢 工具、预览、真机调试 都没有报错并且可以调起授权的啊

    这。。。。 😳😢

    03-02
    有用 1
    回复 9
    • ᴶᵃᶜᵏ
      ᴶᵃᶜᵏ
      03-02
      安卓可以,IOS 不行 😢
      03-02
      回复
    • 默
      03-02回复ᴶᵃᶜᵏ
      删除重新扫码呢?
      或者多换几个基础库版本试下
      03-02
      回复
    • JuiceHu
      JuiceHu
      03-03
      是直接调用吗? 我今天用的时候直接调用会报 getUserProfile:fail can only be invoked by user TAP gesture,2.15.0的基础库,Nightly版本1.05.2103022的开发者工具,真机也不行
      03-03
      回复
    • 默
      03-03回复JuiceHu
      通过catchtap点击事件绑定的  不是放到页面onload调用的
      03-03
      回复
    • JuiceHu
      JuiceHu
      03-03回复
      这样子,文档又没有说清楚
      03-03
      回复
    查看更多(4)
  • 清茶涩
    清茶涩
    03-17

    我线上一批用户报错,查看微信的日志都是2.13的基础库,不是说了2.10以上就支持了吗。凉的很

    03-17
    有用
    回复 2
    • 哈罗哈皮
      哈罗哈皮
      04-21
      我也是,你怎么解决?
      04-21
      回复
    • 清茶涩
      清茶涩
      04-21回复哈罗哈皮
      if判断下有没有这个方法
      04-21
      回复
  • 意难平
    意难平
    03-03

    我刚刚用也报错

    03-03
    有用
    回复 1
    • 意难平
      意难平
      03-03
      版本库过低导致,最低2.10.4
      03-03
      回复
  • 跨商通
    跨商通
    03-02

    微信的版本需要升级?

    03-02
    有用
    回复
  • ᴶᵃᶜᵏ
    ᴶᵃᶜᵏ
    03-02
    console.log('getUserProfile', wx.getUserProfile)
    console.log('canIUse', wx.canIUse('wx.getUserProfile'))
    


    这。。。。 😳😢



    03-02
    有用
    回复 2
    • Lu
      Lu
      03-05
      请问这个问题解决了吗
      03-05
      回复
    • ᴶᵃᶜᵏ
      ᴶᵃᶜᵏ
      03-05回复Lu
      没有呢
      03-05
      回复
登录 后发表内容
问题标签