收藏
回答

wx.getMenuButtonBoundingClientRect报错,方法未定义?

代码是:let wxBtnMenu = wx.getMenuButtonBoundingClientRect();

然后报错未定义,这是什么鬼啊....

title-bar.js? [sm]:3 Uncaught TypeError: wx.getMenuButtonBoundingClientRect is not a function

回答关注问题邀请回答
收藏

1 个回答

  • 仙森ღ₅₂₀¹³¹⁴
    仙森ღ₅₂₀¹³¹⁴
    2019-10-04

    这个 api是 2.1.0版本支持的,你的用户有的客户端基础库版本 小于这个基础库。你在小程序后台设置下 最低基础库2.1.0.那样用户客户端基础库版本低于2.1.0就会提示升级

    2019-10-04
    赞同
    回复 4
    • DESTINY 〆
      DESTINY 〆
      2019-10-04
      thanks so much
      2019-10-04
      回复
    • 仙森ღ₅₂₀¹³¹⁴
      仙森ღ₅₂₀¹³¹⁴
      2019-10-04回复DESTINY 〆
      you are welcome
      2019-10-04
      回复
    • 陈炆
      陈炆
      2019-12-24
      怎样在开发工具中指定?我在后台设置对开发工具那边的版本没有作用
      2019-12-24
      回复
    • 仙森ღ₅₂₀¹³¹⁴
      仙森ღ₅₂₀¹³¹⁴
      2019-12-24回复陈炆
      开发者工具  详情里
      2019-12-24
      回复
登录 后发表内容
问题标签