收藏
回答

开发者工具更新后项目报错

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows 1.02.1907222

- 当前 Bug 的表现(可附上截图)

公司开发小程序,用到了第三方平台需要读取相关的配置,今天更新了最新的小程序开发者工具,起项目就报错了,让同事升级最新的开发者工具后也变成这样


根据提示找到相关的文件,发现并有报错提示中的问题


- 预期表现

正常访问开发

- 复现路径


- 提供一个最简复现 Demo

使用第三方开放平台,项目中进行ext.json的配置



回答关注问题邀请回答
收藏

3 个回答

  • 社区技术运营专员-小柿子
    社区技术运营专员-小柿子
    2019-07-23

    这文件找不到?

    2019-07-23
    赞同
    回复 1
    • Gary杭
      Gary杭
      2019-07-23

      有这个文件,项目下ext.json配置格式像下面这样

      {

          "extEnable": true,

          "extAppid": "aaaaaaa",

          "ext": {

              ....其他配置

          }

      }

      extEnable配置为false就没有错误。但是也读取不到开放平台的配置了

      2019-07-23
      回复
  • \
    \
    2019-07-24

    每次更新完都有些小毛病,问题不大,用回旧版试试。

    2019-07-24
    赞同
    回复
  • 朱公朴
    朱公朴
    2019-07-23

    确定 ext.json 里面的 extAppid 是 string 类型么?

    2019-07-23
    赞同
    回复
登录 后发表内容