收藏
回答

引入小程序直播插件报错,请问是否有最低基础库版本要求?

1,微信基础库2.6.2及以下版本,引入直播间插件后,报错

2,微信基础库2.2.1及以下版本,引入直播间插件后,会多报另一个错

请问,直播间是否对基础库版本有最低要求?

最后一次编辑于  2020-05-07
回答关注问题邀请回答
收藏

3 个回答

  • 阿卢说他遇到阿玮
    阿卢说他遇到阿玮
    2020-05-07

    这是官方文档的截图,推荐的基础库版本是2.9.x以上。

    而我用的基础库版本是2.8.3,而且能正常使用。

    你可以直接更改基础库版本试试不就知道最低版本是多少了么。

    2020-05-07
    有用
    回复 1
    • 姚冀锋
      姚冀锋
      2020-05-07
      嗯,我试了三个2.9.x以下的版本,正好把结果也同步给你。
      2.2.1 会有报错,进入直播间会黑屏
      2.8.3 进入直播间之后显示了“建议升级”的提示
      2.5.2 进入直播间之后没有显示提示
      2.8.3和2.5.2都可以显示直播视频,但是没有“同层渲染”,导致没有商品的跳转。
      2020-05-07
      1
      回复
  • 👨比金🇨🇳
    👨比金🇨🇳
    2020-05-07

    我这引不进来是怎么回事

    2020-05-07
    有用
    回复 4
    • 姚冀锋
      姚冀锋
      2020-05-07
      直播插件需要做直播授权,授权之后才能引入。
      2020-05-07
      回复
    • 👨比金🇨🇳
      👨比金🇨🇳
      2020-05-07回复姚冀锋
      后台已经开通成功
      2020-05-07
      回复
    • 姚冀锋
      姚冀锋
      2020-05-07回复👨比金🇨🇳
      老哥,你看下你的功能菜单里面,有没有直播
      2020-05-07
      回复
    • 👨比金🇨🇳
      👨比金🇨🇳
      2020-05-10回复姚冀锋
      有的
      2020-05-10
      回复
  • 姚冀锋
    姚冀锋
    2020-05-07

    引入的直播插件为1.0.9版本

    "plugins": {
      "live-player-plugin": {
        "version": "1.0.9",
        "provider": "wx2b03c6e691cd7370"
      }
    }
    
    2020-05-07
    有用
    回复
登录 后发表内容
问题标签