收藏
回答

wx.getUserProfile在2.14.1基础库not a function?

翻看小程序错误日志发现的

做了基础版本判断,低于2.10.4会提示版本过低,这种高于2.10.4的版本 该怎么解决

回答关注问题邀请回答
收藏

3 个回答

  • 微盟
    微盟
    03-11

    https://developers.weixin.qq.com/community/develop/article/doc/00040885c386f81e96cbf93cf51013希望对你有帮助

    03-11
    有用 2
    回复 6
    • 爆矮
      爆矮
      03-11
      03-11
      回复
    • 爆矮
      爆矮
      03-11
      这个直接判断wx.getUserProfile 是怎么判断,能麻烦您给的代码实例么
      03-11
      回复
    • Brother斌🎈
      Brother斌🎈
      03-11回复爆矮
      if(wx.getUserProfile){}
      03-11
      2
      回复
    • 爆矮
      爆矮
      03-11回复Brother斌🎈
      好嘛 我就多了个()就报错了 明白了
      03-11
      回复
    • Brother斌🎈
      Brother斌🎈
      03-11回复爆矮
      加油 我等你们踩完坑 我再改这个需求
      03-11
      回复
    查看更多(1)
  • 默
    03-11

    高于并不代表高于的每个版本都可以调用的

    参考以下版本

    03-11
    有用 1
    回复 1
    • Mꫀꫀt ꪗꪮꪊ .🇨🇳
      Mꫀꫀt ꪗꪮꪊ .🇨🇳
      06-16
      2.14.1也不支持,都不知哪个版本支持的;升级了开发者工具也不行
      06-16
      回复
  • 🐠糖醋鱼
    🐠糖醋鱼
    05-08

    同遇到这个问题,电脑版小程序,不管是工具电脑版真机预览还是电脑版直接打开小程序都是这个问题,请问你解决了吗?

    05-08
    有用
    回复
登录 后发表内容
问题标签