收藏
回答

为什么模拟器上没有编译错误,真机调试和预览就会说编译错误?


图二我把图一显示的208附近代码注释了,然后又报错另外一个页面的错,也没显示哪里的错,这个页面昨天用的好好的,今天就报错?而且模拟器上没有编译错误,真机调试和预览就会说编译错误

回答关注问题邀请回答
收藏

4 个回答

  • reus
    reus
    2019-10-31

    有这个报错 请仔细按照报错提示检查代码 是否存在属性漏写""或者只写了一个" 模拟器后续也会同步过来这个编译 到时候在模拟器上也会报错

    2019-10-31
    有用
    回复
  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    2019-10-30

    麻烦提供工具的版本号,并提供能复现问题的简单代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)。

    2019-10-30
    有用
    回复 6
    查看更多(1)
  • Sober
    Sober
    2019-10-30

    我也是啊 昨天还能预览 今天就和你一毛一样的情况

    2019-10-30
    有用 1
    回复 11
    • 要这头发有何用
      要这头发有何用
      2019-10-30
      好难受 代码都没动过
      2019-10-30
      回复
    • Sober
      Sober
      2019-10-30回复要这头发有何用
      我想真机测点东西 现在坐着发呆 直接把报错的页面注释掉 他就继续报下一个页面
      2019-10-30
      回复
    • 要这头发有何用
      要这头发有何用
      2019-10-30回复Sober
      真的好绝望
      2019-10-30
      回复
    • 要这头发有何用
      要这头发有何用
      2019-10-30回复Sober
      我解决了  模拟器能跑 真机调试报2个页面编译错误,原因是每个页面两个属性少“,
      2019-10-30
      回复
    • Sober
      Sober
      2019-10-30回复要这头发有何用
      什么属性啊老哥
      2019-10-30
      回复
    查看更多(6)
  • lee. jw
    lee. jw
    2020-03-05

    我也是同样的问题。昨天还能预览。

    2020-03-05
    有用
    回复 3
    • Sober
      Sober
      2020-03-05
      你看下你app.json里面的页面路径是不是差了些没写
      2020-03-05
      回复
    • lee. jw
      lee. jw
      2020-03-05回复Sober
      谢谢,我这个是引用的模板文件。昨天还没有问题。今天就是回退到昨天版本还是有问题。之前出现过这样的情况,我重命名了模板文件去掉了中间的"-",然后问题解决了。(之前模板文件的名字是"car-list-main"
      2020-03-05
      回复
    • lee. jw
      lee. jw
      2020-03-05回复lee. jw
      问题解决了,把templates文件夹移到pages里面就可以了。要不然可能被忽略没有上传。
      2020-03-05
      回复
登录 后发表内容
问题标签