收藏
回答

新版开发者工具1.03.2012120 bug?装回旧版本就好了

系统:WIN10X64 node:v14.15.4 npm:6.14.10 开发者工具:1.03.2012120

BUG:

更新开发者工具版本,云函数内部终端npm安装依赖报错

→使用cnpm,内部终端安装依赖成功,云函数本地调用成功,上传所有文件后云端调用不了,云端安装依赖可以调用

→关闭项目,外部终端npm安装依赖成功,回到工具新建云函数内部终端npm安装依赖成功,但是同时打开第二个云开发项目时,一直显示加载中

→关闭所有项目,开发者工具崩了启动不了,没有任何反应

→重装开发者工具/重装32位开发者工具,均出现:打开第一个云开发项目可以启动,同时打开多个云开发项目又出现上述同样的问题;重装node/重启电脑...只要之前出现过打不开项目的情况,启动开发者工具就一直没反应

→重装预发布版(1.03.2012121),开发者工具可以启动,可以打开多个云开发或者非云开发项目

→但是!内部终端npm安装依赖报错!外部终端npm安装依赖报错!只有每次关闭要安装依赖的项目(其他项目不用关闭),外部终端npm才能成功!

而且没有实现上述外部安装成功一次,之后再回到工具可以成功安装的情况

没有装node的情况下,打开任务管理器,可以看到开发者工具有node的进程在运行...本人非开发出身,没有技术背景,在学习云开发...纯靠猜测是不是开发者工具内置的node跟系统安装的node存在某种冲突?

装回之前前的版本,一切都好了...白白给微信开发者工具团队做了三天测试...我居然以为官方只能下载到当前展示的版本,这一顿捣鼓...以后再也不瞎更新了

1.03.2011120版本:

https://developers.weixin.qq.com/community/minihome/doc/0000a0b95a8800310f5b95eca5c801

最后一次编辑于  01-13
回答关注问题邀请回答
收藏

3 个回答

  • 工号 019743
    工号 019743
    01-13

    所以报啥错呢?有截图么

    01-13
    有用 1
    回复 4
  • 王马利
    王马利
    01-13

    我可能遇到了两个问题:

    1.安装依赖有BUG是肯定的

    2.多开项目失败是不是因为安装依赖错误造成的?不确定,可以确定的是开发者工具只要崩一次,在没有重新安装的情况下是启动不了的,重启电脑也启动不了


    01-13
    有用 2
    回复
  • 张老师
    张老师
    01-13
    试试nightly版本?https://developers.weixin.qq.com/miniprogram/dev/devtools/nightly.html
    01-13
    有用 1
    回复 1
    • 王马利
      王马利
      01-13
      试了  跟预发布版本一样的
      01-13
      1
      回复
登录 后发表内容
问题标签