收藏
回答

自定义底部tabbar组件,不能设置层级。存在问题:遮罩层遮不住底部tabbar

框架类型 问题类型 终端类型 微信版本 基础库版本
小程序 Bug 微信iOS客户端 7.0.12 2.10.3

https://developers.weixin.qq.com/miniprogram/dev/component/cover-view.html

官方示例模板,添加个遮罩层足以复现问题。



最后一次编辑于  2020-03-26
回答关注问题邀请回答
收藏

4 个回答

  •  
     
    07-22

    从网上找到了解决方式。把自定义遮罩层层级改成10000,我试了有用,搜索到这个问题的可以参考

    07-22
    有用 1
    回复 2
    • 你
      08-20
      我设置了,怎么还是不起作用呢
      08-20
      回复
    • 四方之下谓之宇
      四方之下谓之宇
      10-30回复
      结合一楼和二楼就可以了
      10-30
      回复
  • 俗人
    俗人
    2020-07-16

    自定义tabbar组件时你可以使用view和image,不使用cover-view和cover-image

    2020-07-16
    有用 1
    回复
  • 是柿子啊
    是柿子啊
    2020-03-26

    正常情况,cover-view 的层级比较高

    2020-03-26
    有用
    回复 1
    • 低气压
      低气压
      2020-03-26
      提示的第十三点能说明一下?
      tip: 支持使用 z-index 控制层级


      遮罩层的层级比我自定义Tabbar层级更高,为什么还是Tabbar显示在顶层,层级的用处是怎样的?
      2020-03-26
      1
      回复
  • Lv: Max Human
    Lv: Max Human
    2020-03-26

    写个代码片段吧。

    2020-03-26
    有用
    回复 1
登录 后发表内容
问题标签