收藏
回答

1.9.94版本 自定义组件报jsEnginScriptError

框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
小程序 Bug 自定义组件 工具 1.9.94 1.9.94


/***************************************************************************/

modal.wxss文件

<view hidden='{{modalHidden}}'>

<view class='mask_layer' bindtap='modal_click_Hidden' />

<view class='modal_box'>

<view class="title">提示</view>

<view class='content'>

<text class='modalMsg'>{{modalMsg}}</text>

</view>

<view class='btn'>

<view bindtap='modal_click_Hidden' class='cancel'>取消</view>

<view bindtap='Sure' class='Sure'>确定</view>

</view>

</view>

</view>

/***************************************************************************/


modal.json文件


{

"components":true

}


/***************************************************************************/

modal.js文件



Component({

properties: {

modalHidden: {

type: Boolean,

value: true

}, //这里定义了modalHidden属性,属性值可以在组件使用时指定.写法为modal-hidden

modalMsg: {

type: String,

value: ' ',

}

},

data: {

// 这里是一些组件内部数据

text: "text",

},

methods: {

// 这里放置自定义方法

modal_click_Hidden: function () {

this.setData({

modalHidden: true,

})

},

// 确定

Sure: function () {

console.log(this.data.text)

}

}

})


这是我按照网上的博客写的,但是写完modal.js文件就已经报错了,请问这个自定义组件怎么写啊?

回答关注问题邀请回答
收藏

2 个回答

  • 姜Lulu. 🎏
    姜Lulu. 🎏
    2018-07-20

    有,开发者工具上没,真机上报错。

    2018-07-20
    赞同
    回复
  • 晨
    2018-07-01

    使用新版本还有问题吗?

    2018-07-01
    赞同
    回复
登录 后发表内容