收藏
回答

关于移植Lottie动画库的使用

我最近想在微信小程序上跑一下Lottie,在GitHub上把大佬的代码clone下来后结果example没跑起来,新建一个空项目按readme来用npm安装Lottie-miniapp第三方库,结果也一直报错。想问一下有没有大佬尝试过能跑起来?配置了两天一直没有什么进展。


下面是大佬的Lottie-miniapp项目地址

https://github.com/landn172/lottie-miniapp

最后一次编辑于  03-18
回答关注问题邀请回答
收藏

3 个回答

  • 铭锋科技
    铭锋科技
    03-18

    注意路径不要搞错

    另外也可以使用组件形式

    03-18
    赞同 1
    回复
  • zxb000
    zxb000
    07-17

    大佬的方法是对的,要先把大佬的包 build 成组件,然后再加载到小程序组件里依赖,我的跑通来,就是用的这位大佬的包,顺手修复了下:this.createIntersectionObserver([options]) 的问题,可以参考我的项目:https://github.com/zxbin2000/lottie-miniapp

    07-17
    赞同
    回复 2
    • 驰子
      驰子
      07-19
      谢谢分享
      07-19
      回复
    • 茶与布朗
      茶与布朗
      08-21
      参考你的项目 运行 lib.js报错啊 example的demo也看不了
      08-21
      回复
  • cici-evil girl
    cici-evil girl
    07-11

    我的也一直报错   请问你的问题解决了吗

    07-11
    赞同
    回复