收藏
回答

最新开发工具的BUG!!!

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows 1.02.1901221

- 当前 Bug 的表现(可附上截图)

起初我以为是打包的问题,后来在重复操作安装卸载了几个版本后,定位到是最新开发工具的bug


具体表现为:

当把自定义组件在app.json中全局声明的时候,自定义组件的引用会出错,且页面js中使用

selectComponent完全无法获取组件实例!!!该行为在开发工具上直接编译是正常的,点击预览的开发版和提交的体验版都会表现出无法获取实例!!


这个问题非常严重,直接导致目前使用最新工具提交的体验版中无法使用自定义组件!!


麻烦官方看看,为啥每次过年的时候就不让好好过年了

(代码片段无法提供,因为只能预览的时候才能在调试里看出问题,代码片段无法预览)


================================1.24更新

最新版本官方已发,上一个稳定版本官方已提供,请到工具下载页查看


最后一次编辑于  2019-01-24
回答关注问题邀请回答
收藏

22 个回答

  • Can🌴
    Can🌴
    置顶回答2019-01-25

    更新下1.02.1901230

    2019-01-25
    赞同
    回复 1
    • 猫神
      猫神
      2019-01-25

      麻烦你们更新一个稳定的版本  哪怕出了问题  给一个通知   别出了问题等人测出来在修复  我们还过年不?  都是程序员  互相体谅下 行吗?

      2019-01-25
      3
      回复
  • cheny
    cheny
    2019-01-23

    为啥每次过年的时候就不让好好过年了……

    2019-01-23
    赞同 10
    回复 6
    • 凌柏超
      凌柏超
      2019-01-23

      你还指望微信  就算你一切测试通过  都别想过年

      到时候腾讯内部自罚三杯  大家在马路吃剩菜

      2019-01-23
      回复
    • 连胜
      连胜
      2019-01-24

      每次过年,这个词用的好,程序猿就算过年,也要24小时待命,电脑必须摆在手边

      2019-01-24
      回复
    • 凌柏超
      凌柏超
      2019-01-24回复连胜

      额 爱爱时也要准备吗

      2019-01-24
      回复
    • Yoฉันคิดถึง
      Yoฉันคิดถึง
      2019-01-25回复凌柏超

      测试

      2019-01-25
      回复
    • Yoฉันคิดถึง
      Yoฉันคิดถึง
      2019-01-25回复Yoฉันคิดถึง

      测试

      2019-01-25
      回复
    查看更多(1)
  • L°
    2019-01-25

    最新版不支持十六进制了???

    2019-01-25
    赞同 5
    回复 2
  • 🦀
    🦀
    2019-01-23

    +1

    2019-01-23
    赞同 3
    回复
  • 管凯旋
    管凯旋
    2019-01-23

    提供报错截图一张

    2019-01-23
    赞同 3
    回复
  • 仙森ღ₅₂₀¹³¹⁴
    仙森ღ₅₂₀¹³¹⁴
    2019-01-24

    底部tabbar切换 除了 第一个 第二三四 切换都不会换成选中的图片 颜色也不会变。真机正常

    2019-01-24
    赞同 2
    回复 4
  • ᕕ(ᐛ)ᕗ
    ᕕ(ᐛ)ᕗ
    2019-01-23

    +1

    2019-01-23
    赞同 2
    回复
  • 社区技术运营专员-灵芝
    社区技术运营专员-灵芝
    2019-01-23

    已反馈哈

    2019-01-23
    赞同
    回复 6
    • 🦀
      🦀
      2019-01-23

      简单点说,这个Bug就是【新版开发者工具无法识别app.json里面的usingComponents】

      2019-01-23
      4
      回复
    • 土豆豆
      土豆豆
      2019-01-23

      想要过个安稳年真难!!!

      2019-01-23
      3
      回复
    • 土豆豆
      土豆豆
      2019-01-23

      官方大大给个历史版本的下载链接吧,最新的这个没法用了

      2019-01-23
      回复
    • 社区技术运营专员-灵芝
      社区技术运营专员-灵芝
      2019-01-23回复土豆豆

      可以试一下这个beta版本的,Beta 版本安装不会覆盖正式版本的安装路径

      https://developers.weixin.qq.com/miniprogram/dev/devtools/beta.html

      2019-01-23
      回复
    • 土豆豆
      土豆豆
      2019-01-23回复社区技术运营专员-灵芝

      ok

      2019-01-23
      回复
    查看更多(1)
  • 黎😄
    黎😄
    2019-01-25

    一般来说,只要当前这个开发工具没什么大问题,新出的功能还不是很想要,

    请不要更新开发工具!

    请不要更新开发工具!

    请不要更新开发工具!

    否则,

    掉坑吧!

    掉坑吧!

    掉坑吧!

    2019-01-25
    赞同 1
    回复
  • 衬衫
    衬衫
    2019-01-23

    更新下:

    这个login组件是在app.json里声明的

    ==================================

    在onload里面

    console.info(_this.selectComponent("#login"));

    控制台打印的是null,但页面里面已经有login组件了


    2019-01-23
    赞同 1
    回复 3
    • 胡说胡话是傻子
      胡说胡话是傻子
      2019-01-23

      你放到onshow里面应该就有了,看下生命周期详解

      2019-01-23
      回复
    • 凌柏超
      凌柏超
      2019-01-23回复胡说胡话是傻子

      老子之前用的好好的  也是同样问题 跟新一个工具版本就要陪着加班吗

      2019-01-23
      回复
    • 衬衫
      衬衫
      2019-01-24回复胡说胡话是傻子

      换了个开发工具就好使了,不是onload的问题

      2019-01-24
      回复

正在加载...

登录 后发表内容