收藏
回答

Failed to load media?

在开发带视频的小程序,遇到问题,大佬有没有什么解决方案

回答关注问题邀请回答
收藏

9 个回答

  • 追寻
    追寻
    2021-01-20
    • 问题原因:通常是由于系统设置了代理如Shadowsocks等。
    • 解决方案:关闭代理,点击工具栏“设置”-“代理设置”,选择“不使用任何代理,勾选后直连网络”。

    参考https://blog.csdn.net/wlchn/article/details/54426864


    2021-01-20
    有用 4
    回复 2
    • .
      .
      2021-07-22
      亲测无效
      2021-07-22
      回复
    • 小趙
      小趙
      2021-11-03
      我开发版的开发工具默认就是不使用任何代理,点开之后死心
      2021-11-03
      回复
  • 小李许的什么愿
    小李许的什么愿
    2021-07-12

    组件添加autoplay自动播放就好了,不加也不会影响使用

    2021-07-12
    有用 1
    回复 3
    • 凌晨丶傍晚
      凌晨丶傍晚
      2021-09-23
      我添加autoplay没问题了
      2021-09-23
      回复
    • me
      me
      2021-12-31
      那如果不需要自动播放怎么办
      2021-12-31
      回复
    • .    ⃢👁-👁⃢     .
      . ⃢👁-👁⃢ .
      04-13
      添加autoplay="{{false}}",亲测有效
      04-13
      回复
  • 小川
    小川
    2020-10-14

    把这两个 必填属性添加上就OK了

    <video ad-unit-id poster-for-crawler src=""></video>

    2020-10-14
    有用 1
    回复 8
    • 想我的时候
      想我的时候
      2020-10-15
      还是报这个错误,怎么办呀
      2020-10-15
      回复
    • 小川
      小川
      2020-10-16回复想我的时候
      你仔细看看报的错误是这个嘛
      2020-10-16
      回复
    • ﹉续写不尽的未来
      ﹉续写不尽的未来
      2020-10-26
      你的应该和我们要的不一样哦,加了照常报错
      2020-10-26
      回复
    • vie.
      vie.
      2020-11-24
      并不能解决
      2020-11-24
      回复
    • 缄口
      缄口
      2021-06-09
      并不能解决
      2021-06-09
      回复
    查看更多(3)
  • 泛黄
    泛黄
    2020-12-09
    wx:if="{{avatarUrl}}" src="{{avatarUrl }}"或者src="{{avatarUrl ? avatarUrl : '/assets/images/avartar_default.png'}}"试试
    
    
    2020-12-09
    有用
    回复
  • 查无此人
    查无此人
    2020-09-01

    可能是开发者工具现在不支持调试video了 live-player也一样但是手机不报错

    2020-09-01
    有用
    回复 1
    • 小川
      小川
      2020-10-14
      来看解决办法
      2020-10-14
      回复
  • An
    An
    2020-06-04

    在video组件上,试试加个custom-cache=”{{false}}”属性,可以完美解决卡顿、绿屏的现象,参考

    https://blog.csdn.net/worldmakewayfordream/article/details/79968630?utm_medium=distribute.pc_relevant.none-task-blog-baidujs-3


    2020-06-04
    有用
    回复 1
    • 👾
      👾
      2020-08-06
      没用
      2020-08-06
      回复
  • 堡垒
    堡垒
    2020-05-31

    我也遇到这个问题,电脑上调试声音播放正常,苹果手机又无法播放,不知道什么原因

    2020-05-31
    有用
    回复
  • 大胖脸
    大胖脸
    2020-05-12

    在开发者工具上,我也遇到了和你一模一样的问题;手机上可以正常播放视频,不知道为啥?

    2020-05-12
    有用
    回复
  • ㅤ
    2019-11-20

    解决了么




    2019-11-20
    有用
    回复 3
    • 张桐
      张桐
      2020-03-30
      没有
      2020-03-30
      回复
    • cydida
      cydida
      2020-06-10
      问题依然存在
      2020-06-10
      回复
    • 小川
      小川
      2020-10-14回复cydida
      2020-10-14
      回复
登录 后发表内容
问题标签